Support » Plugin: Easy Forms for Mailchimp » Form error when api is changed

  • Resolved VaDims

    (@vadims00)


    Hello
    How do we deal with the problem that forms are getting blocked when api is changed?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Tracy Levesque

    (@liljimmi)

    🏳️‍🌈 YIKES, Inc. Co-Owner

    Hi @vadims00

    Did you try clearing the API cache?
    https://yikesplugins.com/support/knowledge-base/api-cache-settings/

    If that didn’t work, please check out this article on Mailchimp blocking your site.
    https://yikesplugins.com/support/knowledge-base/are-you-being-blocked-by-mailchimp/

    Let us know how it goes.

    Thank you.
    -Tracy

    Plugin Contributor Tracy Levesque

    (@liljimmi)

    🏳️‍🌈 YIKES, Inc. Co-Owner

    Hello @vadims00,

    Just checking in.

    Please let us know if you still need help with this issue.

    Thank you!
    -Tracy

    Thread Starter VaDims

    (@vadims00)

    Hello
    I have cleared the api cache multiple times and no, I’m not being blocked by Mailchimp.
    Still I can’t connect to another account when changing api keys.

    Plugin Contributor Tracy Levesque

    (@liljimmi)

    🏳️‍🌈 YIKES, Inc. Co-Owner

    Hi @vadims00,

    How did you confirm your IP address isn’t being blocked?

    Do you have another website you can install the plugin and try to connect with the same API key? This would be a great troubleshooting step to see if it’s something with the Mailchimp account or the hosting environment.

    Thank you.
    -Tracy

    Plugin Contributor Tracy Levesque

    (@liljimmi)

    🏳️‍🌈 YIKES, Inc. Co-Owner

    Hello @vadims00,

    We haven’t heard back from you in a while so I am going to close out this ticket.

    If you need more help, please reopen it and we will be happy to help you.

    Thank you!
    -Tracy

    Thread Starter VaDims

    (@vadims00)

    Hey
    I’m reopening this since no solution was found

    The form was working fine with the api for a temp mailchimp account but after changing the api to the permanent one it breaks the form. The screenshots below are taken after changing the api:

    https://pasteboard.co/Job2LJk.png
    https://pasteboard.co/Job1eXy.png
    https://pasteboard.co/Job0LmS.png

    I can tell that my ip is not being blocked by mailchimp since it was working fine with the first api. The problem occurs only after changing the api.

    Thread Starter VaDims

    (@vadims00)

    Any updates on this one?

    Thanks!

    Plugin Contributor Freddie

    (@fmixell)

    Hey @vadims00,

    Did you see this message:

    Warning: changing your api key may break your forms

    Looks like you only have one form, have you tried to delete it and then create a new form to replace it?

    – Freddie

    Thread Starter VaDims

    (@vadims00)

    Hey Freddie
    Thank you for your reply!

    Of course I have seen the warning message. And of course I may create the form again, but I’m looking for a workaround without having to do it again. Is there any?

    • This reply was modified 1 year ago by VaDims.
    Plugin Contributor Tracy Levesque

    (@liljimmi)

    🏳️‍🌈 YIKES, Inc. Co-Owner

    Hi @vadims00

    If you saw the warning message and went ahead with it anyway, I’m really sorry, but there is nothing we can do.

    You could restore a backup on a staging site and export the form then import it again on the live site.

    -Tracy

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Form error when api is changed’ is closed to new replies.