Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Form emails blank 'phone' Field

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Could you post the contact shortcode you use on one of your websites, so I can run some tests and try to reproduce?

    Thanks!

    Thanks for reviewing Jeremy:
    [contact-form][contact-field label='Name' type='name' required='1'/][contact-field label='Phone' type='text' required='1'/][contact-field label='Email' type='email' required='1'/][contact-field label='Website' type='url'/][contact-field label='Comment' typ,
    e='textarea' required='1'/][/contact-form]

    I noticed that the phone field is also blank on the confirmation screen (when logged out). It’s really odd that the other fields are processed correctly and that the phone number is present in the message database.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Could you try to delete that form altogether, and create a brand new one?

    Let me know how it goes.

    Yep, I did that before posting and again, I am seeing this on two websites.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    That’s interesting. I’m not sure why I can’t reproduce at the moment. Do you have to run similar plugins on both sites?

    If so, could you try to deactivate any common plugins, one at a time, and let me know if you find a conflicting plugin?

    Thanks!

    Yes. I’ll start turning things off.

    I would have pursued that sooner, but assumed since all the default fields are submitted without issue, there was some kind of a parsing issue.

    Confirmed. W3 Total Cache is the culprit.

    Sorry to have wasted your time, I appreciate you having a look.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Excellent!

    That still could be something we can fix in Jetpack, though. Could you tell me more about your W3 Total Cache settings, so I can try to reproduce and see if we can fix this problem?

    Thanks!

    Geese there are several pages of settings in that plug-in. I’ve had this plugin installed for years (too long to recall what settings have been changed), but with few exceptions, I am taking the defaults. On the second site, I don’t think I have changed any of the defaults.

    I’d be happy to give you log-in so you can review. BTW — I am using the cloudflare option, but the problem continues, even when that option has been disabled.

    I’ve just switched over to WP Fastest Cache (W3 is there, but disabled if you’d like to review).

    WP Fastest Cache seems to be equally fast and isn’t interfering with the form.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    I’m glad to hear you found a work-around.

    Do you think you could send us some screenshots of your W3 Total Cache settings, so we can keep investigating on our end? You can send them to us via this form:
    http://jetpack.com/contact-support/

    Thanks!

    The first panel of settings (there are 8) is 3 printed pages long. So I don’t think a screenshot is going to be of any value. I have printed all of the panels to pdfs.
    You can download them here:
    https://drive.google.com/folderview?id=0B8ssYE7ZFKHJMjZDQ1lDRGg2NVk&usp=sharing

    But honestly, I think if you install W3, enable it and log out (it doesn’t fail when logged in), you’ll be able to reproduce the problem.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Thanks! I couldn’t reproduce with the default W3 settings, but I’ll play with it a bit more and compare my settings with your screenshots to look into this, and see if I can reproduce and fix the problem.

    Thanks for looking. I actually found the issue on three sites (not two). Removing W3 cured the issue in all cases.

    Again, only the issue was only visible if logged out.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Form emails blank 'phone' Field’ is closed to new replies.