Support » Plugin: Gravity Forms Directory » Form editor returns blank when adding Approved option

  • Cole Geissinger


    Love this plugin by the way! It covers everything I need, however while I was testing it out for the first time, I added the Directory Field “Approved”, and after I clicked save, the form loads for a split second then disappears 🙁

    I checked the source code and it’s like the whole entire DOM for the forms is removed. I can’t locate and of the source code when I load the form. The form still displays as all the information is still in the database, but I can’t make any edits now to the form. If I click save I get this message “Please enter a Title for this form. When adding the form to a page or post, you will have the option to hide the title.” It’s detecting that there’s no form settings like what happens when saving a new form that hasn’t been configured?

    Deactivating the plugin, the form displays again so it’s definitely something with this plugin. I also deactivated all plugins bug GF and the Directory Plugin and its still doing it 🙁 I’m running this on my local server running MAMP 2.0.5 on a MacBook Pro 15″ and Gravity Forms 1.6.9

Viewing 15 replies - 1 through 15 (of 27 total)
  • Cole Geissinger


    I pushed on and fixed everything up to my liking (minus the odd disappearing form) and pushed forward with taking this to the live server and it doesn’t have the same issue, although this site is still running 3.4.2… It’s seems to be a 3.5 issue so far.



    Having the exact same issue. Couldn’t figure out what was causing the problem until I started deactivating plugins and this one is the winner!

    Sadly there are no errors thrown and no console messages. Seems to be a JavaScript conflict that clears out the entire form from the <td> with the “pad_top” class.

    Definitely is a 3.5 problem since it worked until the update.

    Ditto on the blank screen with 3.5 installed. It kinda stinks, I bought g f just so that I could use this plugin.

    Let’s hope the author isn’t on holiday till next year. ;(

    The offending code is line 149 in edit-form.php.


    thanks for the update. i’m assuming we need to wait for the author?

    I just installed the plugin for the first time. Sounded perfect. But my form disappears after adding the Approved button as well. Hope we have a quick fix.

    Actually, this is not just related to the Approved functionality. I have two forms that are NOT using this, and my users cannot go in and edit either form. They are seeing a list of their entries, but when they click the link to go to the Single Entry page, it is completely blank. Again, neither of these forms is using the Approved functionality.

    Moderator Bet Hannon


    Support Team Volunteer Coordinator

    Just as an FYI for folks looking for help: we have a similar thread going on the same issue, but no answers yet.

    haha found the fix thanks to Octoberblue.

    It is an issue with line 149 in edit-form.php. Basically the jQuery isn’t closed, so when we hit that if statement, it strips all the HTML out where our forms is. Just update the line to look like this $('td:visible:eq('+colIndex+')', $(this)).html(''));

    The developer was missing a closing parenthesis before the semi-colon. Now we just need to get him to update this simple bug ^_^

    Moderator Bet Hannon


    Support Team Volunteer Coordinator

    W00T! Great work, Cole! That solves the issue!

    I put a link to this post over in the support forum on Zack’s website. Maybe he will see it and push out the fix, but in the meanwhile, we are back in business!


    Awesome, thanks bethannon1! 🙂

    Thanks Cole, it worked as soon as I added the closed parenthesis.

    OT: Does anyone have a simple solution on how to make the directory show listings based upon entry date, going forward where it’s the same criteria, like showing listings from the last 5 days only? I see where you can put in a specific date, but I need it so as each day passes, the directory will continue to show a rolling list from the last 5 days only. Appreciate any assistance.

    Well spotted Cole.

    That fixed it for me

    Once you make this fix, are you all seeing the Approved column (red stop signs and green check marks) on your Entries page? That is the only thing I want this plugin for, and it is not showing up. See

    I’d really be interested to know if anyone is seeing this column.


    This fix does not fix the approve/disapprove bug. I can try digging in and see if I can find the bug.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Form editor returns blank when adding Approved option’ is closed to new replies.