Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » Form doesn't submit/Error on submitting

  • Resolved afroniquely

    (@afroniquely)


    I updated to the latest version, I created a WPForm and included it in the contact section of my one page site. But when I tested filling the form out and submitting it (using another email address than my admin email so I could see if it would send), it tries to reload the page and also doesn’t submit anything.

    In the form settings for the particular form I set it that when they submit it should show a message, but it is instead trying to reload the page. Any ideas why it’s behaving this way?

    https://wordpress.org/plugins/wpforms-lite/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter afroniquely

    (@afroniquely)

    Updated to now add:

    I’ve since followed your recent blog post tutorial and now set up using MailGun..so I’m testing using that set up. However when I hit the submit button, it still reloads the page, it seems that the form does indeed submit, but I’m not sure why the page is reloading if it should only be showing a Thank You message when they submit the form. How can I get it to do that?

    Thread Starter afroniquely

    (@afroniquely)

    And another thing I noticed, the box keeps getting spammed now ever since I placed this support request (keep getting random John Doe’s filling the form out). Does the honeybox help block spam? And is there a way that for the website url text input field, it shows the actual URL they entered when the email comes, because right now it shows up as a garbled string until you click the link (which with the box already being spammed, I can bet the links the spammers include will be bad ones).

    Plugin Author Jared Atchison

    (@jaredatch)

    The John Doe submission was me testing the form earlier, so that is where that came from.

    I see what’s happening here. The page reloading is normal as that is the form processing.

    In this particular scenario, things are setup where by default the form is hidden unless the user clicks the button to toggle showing it. So what happens is when the form submits the confirmation message is hidden. It’s there, but you don’t see it unless you go down there and re-toggle the contact form area http://cl.ly/301r3K1H1t1m

    The way to resolve this is to simply create a seperate Thank You page and configure the form to display that page instead of the thank you message.

    Hope that makes sense!

    Thread Starter afroniquely

    (@afroniquely)

    Ok, thanks! That makes sense. I’ve since upgraded to the paid version of WPForms as well 🙂 I just have a quick question though for the forms still. I notice even though I submitted entries (and have now confirmed receipt of them), in the WP Admin area for WPForms it’s not stating that there are any entries, any ideas why?

    And also, if I create a custom thank you page, can I set it to at least open in a modal or a new window, and how would I do that in WPForms?

    Thanks for your help!

    Plugin Author Jared Atchison

    (@jaredatch)

    Awesome!

    Can you please shoot us a support ticket regarding your issue? https://wpforms.com/account/support/

    This will allow me to get additional information (such as WordPress username and password etc) if needed in a secure way.

    Soon as we get the message we can begin to investigate 🙂

    Thank you for your support.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Form doesn't submit/Error on submitting’ is closed to new replies.