Support » Plugin: MC4WP: Mailchimp for WordPress » form doesn’t show on page or in widget

  • Resolved adosharp

    (@adosharp)


    when I put the shortcode on a page, or add the MailChimp Sign-Up Form Widget to my footer, the form doesn’t show up??

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Lap

    (@lapzor)

    Please, as always, post a link to your website where we can see the issue.

    Most likely you are seeing an older version of your website duo to browser or server caching. Make sure to empty your cache on both sides.

    Hope that helps,

    • This reply was modified 2 years, 5 months ago by Lap.

    Thanks for your quick reply!
    Website is at http://fiercestyling.com.au
    am adding the shortcode to a NEW page… and have cleared browser history, and server doesn’t have caching?
    Even when I am in MailChimp for WP > Forms > Preview this form it doesn’t show the form???

    Plugin Contributor Lap

    (@lapzor)

    Hi,

    So where on your website is the form that does’t work? Should it load on the homepage? Because I don’t see the plugin being loaded at all.

    Do you see any error in the javascript console when you try to view the form preview?

    Are you on the latest version of WordPress and MailChimp for WordPress?

    Thanks for letting us know!

    Hi

    The form should be appearing in the Footer Widget under the Stay Connected social media buttons, and also on this page http://fiercestyling.com.au/newsletter-subscribe-2/

    When I look at Preview this form, there is no javascript error, and the form just doesn’t show on the page at all.

    The site is running WordPress 4.7.5 and MailChimp for WordPress V4.1.3. The plugin is connected to the MailChimp account and list. and it is just a very basic form with Name, Email and Submit button! I click on ‘get shortcode’ and then place that on the ‘newsletter-subscribe-2/ page, but the form isn’t showing there or when I have put it in the footer via the widget

    Plugin Contributor Lap

    (@lapzor)

    I noticed that your WordPress is actually installed/setup on /site/ and if i go to http://fiercestyling.com.au/ it seems to be loading just selective parts of your WordPress installation.

    If I go to the full WordPress URL the form works:
    http://fiercestyling.com.au/site/

    But removing the /site/ breaks it. What is the reason it’s setup like this? Do other plugins work in this setup? Can you ask your webdeveloper about this?

    • This reply was modified 2 years, 5 months ago by Lap.

    oh OK, thanks for your advise on that.
    The client’s previous web developer set it up like that, and to be honest, it’s a complete nightmare! Has caused me lots of other problems, and now this.
    The mailchimp for WP plugin is installed in the /site/ folder though… so I would have thought it would work from there?

    Plugin Contributor Lap

    (@lapzor)

    Yes, it does work if you browse to /site/

    I hope you can reverse that setup to get everything working as it should. Good luck!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘form doesn’t show on page or in widget’ is closed to new replies.