Support » Plugin: Caldera Forms - More Than Contact Forms » Form does not submit in Safari

  • Resolved Ynah

    (@ynahpantig)


    Do You Need Immediate Help?
    No, but it would be great if I can get an answer soon.

    Is This A Feature Request?
    No

    What Version Of Caldera Forms, WordPress and PHP Are You Using?
    Caldera Forms >= 1.5.2.1
    WordPress >= 4.9.6
    PHP >= 5.6

    Have also tried with the exact same issue:
    Caldera Forms = 1.7.2
    WordPress = 4.7
    PHP = 7.2.4

    Does Your Issue Persist When You Disable All Other Plugins and Switch To The Default Theme?
    Yes

    What Is The Unexpected Behaviour?
    The form is not submitting when using Safari. Firefox and Chrome are both OK.

    What PHP Errors Have You Logged While Reproducing This Bug?
    None

    What JavaScript Errors Have You Seen While Reproducing This Bug?
    TypeError: undefined is not an object (evaluating ‘b.jqxhr.responseJSON.data’) (http://ace.test/wp-content/plugins/caldera-forms/assets/build/js/ajax-core.min.js?ver=1.5.2.1)
    Failed to load resource: The network connection was lost. (http://ace.test/cf-api/CF5955f653710a5)
    ==

    Note: This is happening both on my local install of the site, as well as in our live site. Please also note that I have tried disabling all plugins and moving back to Twenty Twelve Theme, and still the same result.

    Here is a link to the form on the live site: http://co-op.bc.ca/post-a-co-op-job/
    NOTE: Please note that submissions on this form goes to a lot of different people, not just the admin.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor christiechirinos

    (@christiechirinos)

    We track all bug reports on GitHub, not here. If you have not yet opened this issue there, please do so at https://github.com/CalderaWP/Caldera-Forms/issues/new. The Github issue tracker is not a support channel. It is used for managing our development team. One of our developers will review the issue and determine if it requires a change to Caldera Forms or not and consider all of our users and our road map before addressing the issue.

    Please note that if you do not follow the recommended template, your issue will likely be closed without action from our team because we won’t have the information we need to recreate your problem, to attempt to solve it. Please please please: we need this information to test and recreate the bug in our environment to be able to resolve it.

    Github issues lead to technical discussions: Github is a tool our professional development team uses. Since we develop open-source, you’re very welcome to follow along, or even contribute.

    I hope this is helpful, and please don’t hesitate to reach out if you have additional questions. I’m going to mark this ticket as resolved, but feel free to reopen it if you have further concerns. If you need faster help than what we give on WordPress.org support threads, I hope you’ll consider signing up for Caldera Forms Pro. One of the main benefits is 1 business day turnaround support.

    Hi. I don’t know if this is the same issue, but I saw there’s a ‘file upload’ option on your form.
    Due to a bug, Safari and iPad/iPhone will not submit a form with an empty file-upload option.
    My solution was 2 forms, then detect the browser and display the div with the right form – one with upload, one without for Safari.
    You can see more here. Hope that helps.
    https://stackoverflow.com/questions/51968093/wordpress-htaccess-redirect-single-page-if-iphone-or-safari/51969884#51969884

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Form does not submit in Safari’ is closed to new replies.