Support » Plugin: Genesis eNews Extended » Form communication with ActiveCampaign does not work

  • Resolved alinevandehaar

    (@alinevandehaar)


    Hi,

    I installed this plugin to communicate with ActiveCampaign because the forms from AC are not compatible with the lay out of my website theme. I can get my opt in forms in my sidebar and front page widget but is does not look very good. With your plugin it looks great. Exactly as the rest of my site’s lay out, but…. the forms do not work… If anyone fills out the name and emailfields they get the following message: “this page no longer seems to exist”. I checked with my hosting company (Siteground already and everything works just fine there. AC has not found anything either so far, so hope you can help me solve this…
    I filled out all the necessary fields as far as I know (action form, hidden fields and first name field (I followed this example from an online training) but somehow something is going wrong.

    Can you help me out?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Brandon Kraft

    (@kraftbj)

    Code Wrangler

    Can you send me all of the code from AC as well as what settings you used on your site? Lastly, please send me the URL of your site so I can see the problem in action.

    If there is a 404 error, the form action field is likely wrong.

    Thread Starter alinevandehaar

    (@alinevandehaar)

    Sure I can send you the complete embed code from AC. Can you tell me where to send it? I used the action form and hidden fields in my widget. The code I get is indeed 404 so I tried the action form code without the ” before and after, but then it leads me directly into my active AC account even when using a different email adress so that wasn’t the right solution ;-). I used the code as in the training example I had, but maybe something has changed over time?

    Last my URL: http://www.gezagdelers.nl

    Plugin Author Brandon Kraft

    (@kraftbj)

    Code Wrangler

    It looks like the email form field name setting in the widget is not set, at least for the one in the footer.

    Can you verify that setting? You can drop the form info here—there’s nothing private it in, since it is intended to be added to a site anyhow.

    Thread Starter alinevandehaar

    (@alinevandehaar)

    Email field is filled out now but message is still the same. Oddly enough there is a difference between the two forms alltough they are filled out the same way. The second one gives a new form with a notice that the email adress does not exist (red bar). The first one gives a 404 notion. A made a printscr so you can see what I filled out in the widgets but I can’t attach it here…

    The embed code is the following:

    [Large code excerpt removed by moderator per forum rules. Please use Pastebin or a Gist for all large code excerpts, they work better anyway.]

    • This reply was modified 4 years, 3 months ago by James Huff.
    • This reply was modified 4 years, 3 months ago by James Huff.
    Plugin Author Brandon Kraft

    (@kraftbj)

    Code Wrangler

    It worked for me with the following:

    form action: https://gezagdelers.activehosted.com/proc.php
    email field name: email
    first name field name: fullname
    hidden fields:

    <input type="hidden" name="u" value="6" />
    <input type="hidden" name="f" value="6" />
    <input type="hidden" name="s" />
    <input type="hidden" name="c" value="0" />
    <input type="hidden" name="m" value="0" />
    <input type="hidden" name="act" value="sub" />
    <input type="hidden" name="v" value="2" />
    
    • This reply was modified 4 years, 3 months ago by Brandon Kraft.
    Thread Starter alinevandehaar

    (@alinevandehaar)

    Thanks! I can not find what you did different but I copied your data and it works indeed! Thanks a million!! You really made my day as I am struggeling with this for 3 weeks now!!! Have a great day!

    This helped me too. Thanks Brandon!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Form communication with ActiveCampaign does not work’ is closed to new replies.