Support » Plugins » Hacks » Form Causing a 404 error

  • I have two pages I’ve built, one contains a form and the second contains the PHP code necessary to process the form. The form is here:

    When the form is submitted it goes here:

    Whenever I submit the form I get a 404 error. The page is definitely there, as I can navigate directly to it using the URL above. In fact, when the form is submitted the URL it shows it going to is that exact URL, but it throws a 404 error.

    My only conclusion so far is that the server is not allowing any data to be sent via POST and when I do it acts as if the page doesn’t exist.

    I’ve done this exact same thing countless times on other WordPress installations, this is the first time I’ve ever had a problem. I can only conclude it has something to do with how the servers are set up. The site is hosted via rackspace cloud servers.

    If anyone has any ideas why this happening and what I can do to fix it, I’d be most grateful. (I’m also trying to contact the server tech support, but that is proving to be slightly problematic so far.) Thanks for any insight or suggestions.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have exactly the same problem except my form is using GET.

    James: I finally figured out the problem on my end. It took me hours of troubleshooting but I finally figured out it had to do with the name of an input field. One of the fields on my form used “name” for the “name.” It looked like this:

    <input type="text" name="name" />

    When I changed it to something else, everything worked. I’m assuming there was some kind of conflict with the filed being named “name” from within WordPress. So, I changed it to:

    <input type="text" name="thename" />

    and it’s all good now. Hope this helps.

    backpages: We fixed it the same way. We also worked out why this was causing a problem.

    In 3.1 you can not name a field with a name that is also category name.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Form Causing a 404 error’ is closed to new replies.