WordPress.org

Support

Support » How-To and Troubleshooting » Forgot to backup database before transfering domain

Forgot to backup database before transfering domain

  • I just moved my whole wordpress site to a new server and transferred the domain. Then as I was editing wp-config.php, I realized I did not backup the database from the old site. Now the new site is only showing a blank wordpress blog!
    http://editspaces.com/wordpress/

    If I transfer domain back to the old server temporarily can I backup the database and bring it to the new server?

Viewing 11 replies - 1 through 11 (of 11 total)
  • You could access the database through PHP MyAdmin on your old hosting package and download the .sql file. Then access the database through PHP MyAdmin on the new hosting and upload the database. Since it’s the same domain it should work fine as long as everything is setup the same as far a file structure goes.

    whew, thank god the database is accessible that way! Thank you so much!

    I’ve downloaded the backup and restored it onto via new server’s MySql admin page, the home page is showing up correctly:
    http://editspaces.com/wordpress/

    However, when I click into any post it’s blank???
    http://editspaces.com/?p=970

    I’ve downloaded the backup and restored it onto via new server’s MySql admin page, the home page is showing up correctly:
    http://editspaces.com/wordpress/

    However, when I click into any post it’s blank???
    http://editspaces.com/?p=970

    Nile Flores

    @blondishnet

    Yoast Support

    Is this the same theme you had on the other server?

    Some of your pages seem to be fine. Check your theme templates just in case on your single.php file (or the template for your posts)

    ooooh, I changed the website url to editspaces.com/wordpress and now all posts are working!

    Unfortunately my client would prefer that the homepage be http://www.editspaces.com instead of having to go to editspaces.com/wordpress for the posts to show up. I’ve set blog address to http://www.editspaces.com in Setting>General and I’ve updated the link to wp-blog-header.php but it’s still not working. The home page http://www.editspaces.com won’t show any posts! Please help!

    Nile Flores

    @blondishnet

    Yoast Support

    Why not have the installation instead outside of the /wordpress folder? Install WordPress there instead, and then you can load your theme up as well as the content. If you do not move it up in your filepath, you will still have the problem of it calling to your /wordpress folder.

    Your site seems to also be calling the navigaton from your /wordpress folder.

    Also, is there a reason your Spaces and Contact page have not been converted to WordPress pages yet? You can even put a plugin that will produce a secure contact form there on your Contact page.

    Leave the files in the wordpress directory – WordPress can be “moved” by just copying / editing two files to a new location and making a couple of changes in the Dashboard – keeps the root cleaner – it’s my preferred method.

    if you’re already set up successfully – just move your install to root now
    http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Within_Your_Site
    or
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    blondishnet,

    Do you mean reinstall WordPress to the root directory? Or just copy everything in the wordpress folder to the root directory?

    The reason that Spaces and Contact are not WordPress pages was because the client wanted them to look a certain way, and I decided to save time and do html instead.

    Saildude,

    I’ve done the following steps according to the 2nd link you gave me but the home page is still not loading WordPress:

    # Copy the index.php and .htaccess files from the WordPress directory into the root directory of your site (Blog address). The .htaccess file is invisible, so you may have to set your FTP client to show hidden files. If you are not using pretty permalinks, then you may not have a .htaccess file.
    # Open your root directory’s index.php file in a text editor
    # Change the following and save the file. Change the line that says:
    require(‘./wp-blog-header.php’);
    to the following, using your directory name for the WordPress core files:
    require(‘./wordpress/wp-blog-header.php’);

    Nile Flores

    @blondishnet

    Yoast Support

    You could still template the other pages how you wish… whether you put in a different header, footer or style the page’s php differently itself, so your client can do it either way.

    And yes, I did mean on the main. I know some people install it in /wordpress or /wp, but I see no point anymore to doing that.

    You can always export pages in your WordPress backend from the old and import them into the new.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Forgot to backup database before transfering domain’ is closed to new replies.