WordPress.org

Forums

forgot the WWW in the URL (9 posts)

  1. mikey141414
    Member
    Posted 3 years ago #

    HellO,
    So, I just made a stupid mistake somewhere along the way. i am creating a mobile version of a Flash site. Here is where my site is currently:
    http://m.harvestkitchenandbar.com/

    I think I need it to be here instead:

    http://www.m.harvestkitchenandbar.com/

    Is it as simple as changing the URL in the general settings?

    After this I will have some questions about redirecting for mobile.

    Thanks Mikey141414

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Is it as simple as changing the URL in the general settings?

    No. See Changing_The_Site_URL.

  3. mikey141414
    Member
    Posted 3 years ago #

    Well, I have looked over that documentation, but I think my issue is a little different. You see, my URL currently works just fine. Do I even need to have the www at the beginning? All of my files are in the correct place, so I'm not moving anything. is http://www.example.com in a different location than example.com?

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    is http://www.example.com in a different location than example.com?

    It's a different url, so the above page applies.

  5. mikey141414
    Member
    Posted 3 years ago #

    Ok, so, I tried the first option of editing the wp-config file. That didn't work.

    i tried the functions.php file. That also didn't work.

    So, I went to the database to change the wp-options values. They are already set to http://www.m.harvest....

    So it looks like the database is set up correctly, but wordpress is removing the www somehow?

    mikey141414

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Check your root .htaccess file.

  7. mikey141414
    Member
    Posted 3 years ago #

    Well, there isn't one. But I looked into another blog install and there is one there. Should I change
    RewriteCond %{HTTP_HOST} =

    to my host address?

    mikey141414

  8. esmi
    Forum Moderator
    Posted 3 years ago #

    No.

  9. mikey141414
    Member
    Posted 3 years ago #

    Bo!

    I figure you were trying to say No.

    I appreciate your help and encouragement.

    I will try and search for another solution.
    Thanks!

    mikey141414

Topic Closed

This topic has been closed to new replies.

About this Topic