[resolved] forever-child .custom-header { (5 posts)

  1. technobuddha
    Posted 1 year ago #

    Hi all,
    It seems there's a little snag after I setup a forever-child.
    I used to use the jetpack CSS editor, and all my custom css worked fine.
    BUT, since I now have a working (so I thought), forever-child theme, I put all the custom css into the style.css. Everything works fine, but one weird aspect.

    I have in my forever-child style.css:
    .custom-header {
    text-align: center;

    Well, for some reason, in jetpack it works, but when I disabled jetpack, the setting isn't "kept". Does this mean that the custom-header.php overrides the style.css? that it gets called afterwords?

    but i tried to change the custom-header.php in the forever-child theme, and it didn't work. I had to go to the main forever theme, and change the setting there and it worked!

    soooo, is there something i'm missing?

  2. technobuddha
    Posted 1 year ago #

    a little update. It seems, that the inc/custom-header.php file gets called AFTER the forever-child style.css.

    I read somewhere, where you go and remove_action in the child functions.php file and then add_action to the same function, but named differently it would work. here's the link

    well, it doesn't and I get an error.
    so I suspect i'm doing something wrong.

    I have provided a pastebin so hopefully someone can easily spot what i'm doing wrong!


    Thank you!

  3. Hi there, could you try adding an !important declaration on your style to force it to "take"?

    .custom-header {
    text-align: center !important;

    Let me know how it goes. If you need further help, could you please provide a link to your site so I can take a look directly? Thanks.

  4. technobuddha
    Posted 1 year ago #

    Thank you!
    it worked!

  5. Excellent!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic