Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Foreach and Internet explorer

  • Resolved democle

    (@democle)


    Hi team,

    when giveWP is enabled my site doesn’t load in Internet Explorer (just keeps spinning). The site works fine 100% with any other browser, only IE gives an issue. If I disable giveWP the site works fine in IE too. I have looked the browser console and it looks like the issue is the file wp-content/plugins/give/assets/dist/js/give-stripe.js and the forEach method.

    Is there a way to have that fixed? Perhaps a function that can be disabled?

    Many thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Ben Meredith

    (@benmeredithgmailcom)

    Hi there,

    Can you send along a link to the site, I’m happy to take a look on IE and see what I can find.

    Also, what version of WordPress are you using? That error message makes me think this may be related to the changes to jQuery Migrate that happened in WordPress 5.5, and might be alleviated with this plugin: https://wordpress.org/plugins/enable-jquery-migrate-helper/

    ​​Let me know if that resolves things, or if you need further assistance. ​Thanks for using GiveWP! Have a great day.

    Hi Ben, thanks for your message.

    Unfortunately I am working on local and I am not able to provide a link.
    I haven’t performed the upgrade to 5.5 yet (as it’s too soon and so far no big vulnerabilities have been found on previous version).

    WordPress version: 5.4.2
    GiveWP: 2.7.5

    Plugin Support Matheus Martins

    (@matheusfd)

    Hello @democle,

    Thanks for the information. There is a new version of WP, 5.5.1. Did you have a chance to update it to see if this release fixes the issue?

    Please let us know if you have further questions on this or need any additional assistance!

    Hi Matheus, no I haven’t, I am not even on 5.5 yet as the site is working very well for now (but on on IE). WP 5.4.2 is still safe and testing everything for 5.5 would take me a lot of time. Anyway from what I read online foreach is not supported by Internet explorer, so until the plugin will use I doubt that a WP core version upgrade will help. Correct me if I am wrong

    Plugin Support Matheus Martins

    (@matheusfd)

    Hey @democle,

    I asked that because a few things were changed on WordPress 5.5 and we’ve also updated/fixed things on GiveWP 2.8.0, but you are also using an outdated version.

    If you do not want to update your live site, I suggest you clone it to your local machine and run a few tests on it. Or you can create a staging site too to test the updates. After the updates, feel free to message us if you have problems.

    Have a great day!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.