Support » Plugin: JP's Get RSS Feed » Forced to enter feed url in settings

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author jp2112

    (@jp2112)

    Let me look into this and get back to you. Thx

    Plugin Author jp2112

    (@jp2112)

    The correct parameter name for the feed URL is “url”. You have it written above as “rss”. Please fix this and let me know if the problem still occurs.

    Thread Starter jdimock

    (@jdimock)

    Thanks–I thought that would solve it, but it did not.
    I ran it with this shortcode (tried with single quotes and double quotes):

    [jp-rss-feed url=’http://atgstores.com/account/WishlistFeed.aspx?id=76169&CustomerId=3681326′ numitems=’200′ getdesc=’true’ opennewwindow=’true’ postlinkoptional=’true’ cachetime=’10’]

    I tried the above code where plugin default url was set to blank, and also where it was set to the url.

    When I remove the url from the shortcode, and keep it in the plugin settings, the feed renders fine. Otherwise the feed is blank.

    I am clearing the browser cache with each test, and have set the cachetime to 10 seconds for testing.

    Plugin Author jp2112

    (@jp2112)

    I am having trouble duplicating this issue. I cannot get that feed to display no matter what combination of URLs I use.

    The plugin is designed so that if you leave the default feed URL blank, or put some RSS feed link there, and you override it in the shortcode, then the feed from the shortcode is used. The default is only used when no URL is passed via shortcode or PHP.

    When I put a known feed URL into the plugin settings page and put your URL into the shortcode, it doesn’t work. When I leave the plugin settings page blank and put your URL into the shortcode, it doesn’t work. When I do that with a known feed URL, it works.

    It looks like the feed itself isn’t validating. Can you confirm that you are able to see it?

    Thread Starter jdimock

    (@jdimock)

    Thanks for responding. You can verify the feed url by viewing it directly in Firefox (or another browser, but Firefox displays it nicest).

    You can see the feed working in WordPress on this page: http://www.acres.com.php53-15.dfw1-1.websitetestlink.com/wishlist-3

    It seems to only work under this specific circumstance:
    The url is NOT specified in the shortcode, AND the url IS specified in the plugin settings.

    Plugin Author jp2112

    (@jp2112)

    Thanks to http://scratch99.com/wordpress/development/fetch_feed-url-problem/ I was able to resolve this issue. Look out for the fix in the next release.

    Thread Starter jdimock

    (@jdimock)

    Great, thank you! This will make a big difference for us.

    Plugin Author jp2112

    (@jp2112)

    Also I made it possible for you to use “rss” or “url” as the parameter name. Not that it matters at this point.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Forced to enter feed url in settings’ is closed to new replies.