Support » Plugin: WooCommerce » Force SSL Is GONE

  • Resolved pepwave1

    (@pepwave1)


    My Woocommerce installation does not have a Checkout tab, and it doesn’t have a Checkout option under the Advanced Tab.
    I don’t know how to “Force SSL”…I have other wordpress sites using previous versions of woocommerce, and I have seen the checkbox previously.

    I am using Stripe Connect from WC Vendors as my payment option…but I checked the normal Stripe payment, and there is no “Force SSL” under that one, either.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Force secure checkout is now on the Advanced tab. BUT, without the Checkout tab, there’s also no way to Enable Guest Checkout. I’m trying to launch a site today and this feature is crucial!

    Wait…You can enable Guest Checkout on the Accounts & Privacy page.
    I still can’t find the Force Secure Checkout on the Advanced Tab…it’s literally not on my site.

    Oh thank you! I guess things got moved around during the last release.

    Ok, thanks.
    If you spot the Force SSL box somewhere, can you let me know?

    Plugin Support RK

    (@riaanknoetze)

    Hi there,

    The “Force SSL” option will show up under WooCommerce > Settings > Advanced PROVIDED the site is not loading via HTTPS already.

    If the site does load over HTTPS, the “Force SSL” option will be hidden. If you’d like to toggle “Force SSL” regardless of whether the site is loading via HTTPS, then you’d need to go to https://yourwebsite.com/wp-admin/options.php and look for the woocommerce_force_ssl_checkout options and setting that to either yes or no (Remember to change https://yourwebsite.com with your actual domain).

    Here’s what that looks like on my local testing installation:

    Force SSL using WooCommerce 3.4
    Link to image: http://cld.wthms.co/VX3Reg

    Note: Using the options.php page is for advanced users only – it allows you to change settings directly on your database. In other words – make a backup 🙂

    The Force SSL option is hidden on my site as I’ve got an SSL certificate installed. However, I still get this notification message:

    “Your store does not appear to be using a secure connection. We highly recommend serving your entire website over an HTTPS connection to help keep customer data secure. Learn more here.”

    ???

    Did you change your website settings under Settings>General so that your site name and location both say https://yoursitename.com
    Instead of just http:// ?

    Hi there @pepwave1,

    Thanks for your response!

    Yes, I have changed it to include HTTPS under ‘WordPress Address (URL)’ and ‘Site Address (URL)’ in ‘Settings’ ➝ ‘General Settings’.

    However, looking a bit more into it and comparing to other sites where I’ve made the update, I’m getting suspicious that it has to do with WooCommerce 3.4.0 and the plugin ‘Really Simple SSL’ not being fully compatible at the moment(?). I can see that others are having this issue as well and I’ve let them now that I’m also experiencing it: https://wordpress.org/support/topic/woocommerce-3-4-0-secure-checkout-and-really-simple-ssl-plugin/

    Let’s see if Really Simple SSL provides a solution soon! I’ll let you know here if not.

    Many thanks!

    Plugin Support ryanr14

    (@ryanr14)

    Hi @pepwave1 & @skafte,

    Sometimes there are issues with PHP detecting if an SSL is in use, as well there was a problem with our Stripe extension making this notice appear.

    If your stores still have this notice, can you check if they have PHP 7.0 or newer and the latest version of Stripe (if used on the store).

    Thanks!

    • This reply was modified 1 year, 3 months ago by  ryanr14.
    Plugin Support Melinda

    (@melindahelt)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    same problem – the latest version of PHP – the latest version of Stripe and Woo – running SSL. https:// in all the right places and I’m still getting the error as follows

    “Stripe Cards Settings is enabled and WooCommerce is not forcing the SSL on your checkout page. Please ensure that you have a valid SSL certificate and that you are forcing the checkout pages to be secured.”

    Everything is working in terms of purchases, every page in the process is within SSL – so I’m at a total loss as to understand why the error is showing up.

    @riaanknoetze’s suggestion to edit the options settings does not save settings for me. Any ideas?

    Richard Gates

    (@richardkentgates)

    Same issue here. “Your site doesn’t appear to be using a secure connection.

    PHP 7.2.6 WooCommerce 3.4.5 WordPress 3.4.5 WooCommerce Square 1.0.32, Godaddy Business Hosting and Godaddy SSL Installed, Home and Site URL set to use https.

    stefsterNYC

    (@stefsternyc)

    I love how this has a resolve on it despite not seeing one comment that anyone had success. LOL Who tapped that?

    Same issue here. “Your site doesn’t appear to be using a secure connection.

    PHP version: 7.0.31
    WooCommerce 3.4.5
    Wordpress 4.9.8
    Really Simple SSL 3.0.5
    Let’s Encrypt DV

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.