Support » Plugin: Name Directory » Force personnal traduction

  • Hi !
    For the very particular use of my site, I would like to use different translations from the official translations (for example, Database instead of Directory, or Reference instead of Names)
    I’ve already put my personal.po and.mo in the wordpress languages folder, and it works perfectly.

    But I don’t know why, without updating the application, after a few days, the original translations come back. Can you help me understand?
    Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author jeroenpeters1986

    (@jeroenpeters1986)

    Hey @eurekaindustries,

    I see that you are saying to not update the application, do you mean the plugin? Do you update translations from the WordPress admin? That might be the problem then.

    Officially, no custom translations are supported. They are downloaded automatically from the main WordPress translation platform.
    Do you get French translations when the update happens, or English ones?

    Kind regards,

    Jeroen Peters

    Hi!
    To explain:
    This morning, I loaded the frenchs .po and .mo in /www/wp-content/languages/plugins.
    During the day, without having touched anything, the original French translations came back.
    I don’t want to go back to these translations, but to stay on mine, added manually.
    I’m sure there’s a little bit of code to add manually somewhere to prevent that.
    Thank you for your help, it’s really important!

    Translated with http://www.DeepL.com/Translator

    Plugin Author jeroenpeters1986

    (@jeroenpeters1986)

    Hi @eurekaindustries,

    are you familiair with rights on the filesystem of your webhost, also called CHMOD? If so, you can try to set it with rights 555 (so there is no write-right).

    If that doesn’t work, you could create a cronjob which copies the files over the original ones, let’s say, every 10 minutes.

    I really don’t know how the original translations return, but maybe these two tips will solve your situation.
    Please let me know

    Kind regards,

    Jeroen Peters

    Use the Loco Translate plugin where u can create your own translations.

    If it doesn’t work in default way, create a new language file which isn’t translated yet, and translate the strings that you would like.

    Plugin Author jeroenpeters1986

    (@jeroenpeters1986)

    Thanks for the tip Atilla! I hope @eurekaindustries has some ideas on how to overcome this now.

    Kind regards,

    Jeroen Peters

    Plugin Author jeroenpeters1986

    (@jeroenpeters1986)

    Hi @eurekaindustries,

    did you find a way to get the personal translations?

    Kind regards,

    Jeroen Peters

    eurekaindustries

    (@eurekaindustries)

    Hello,
    no, no solutions. And this is very disabling. I regularly have to submit my translation files via FTP.

    It used to be every 3 or 4 hours.
    Since I tested plugins and installed them as “WP Auto Updater”, it is every 2 or 3 days that the translations are updated.

    But it is done automatically.
    Is there really nothing you can do to block it?

    Plugin Author jeroenpeters1986

    (@jeroenpeters1986)

    Hey @eurekaindustries ,

    that is very weird. I use the translations from translate.wordpress.org, but normally you will have to update them via the admin console (there is a button to download new translations).

    See also this screenshot for what I mean: https://www.cozmoslabs.com/wp-content/uploads/2018/05/Screenshot_20180509_152338.png

    I just found out they are stored in: wp-content/languages/plugins.
    On my own site, the files have not been updated automatically after my own latest manual upgrade action.

    I also read that every site has auto upgrades available by default: https://wordpress.org/support/article/configuring-automatic-background-updates/#core-updates

    You can disable this by entering this in your wp-config.php file:
    define( 'AUTOMATIC_UPDATER_DISABLED', true );

    Would you try this and let us know at the end of the day if they are overwritten again?

    Kind regards,

    Jeroen Peters

    Plugin Author jeroenpeters1986

    (@jeroenpeters1986)

    Btw, the translations via translate.wordpress.org are all automatically, programmers don’t have any influence on how this works.
    What you could do, if you want to block it in another way is to make sure the file cannot be written. You can do so by removing it’s write-rights if you are familiair with file permissions.
    But I should really suggest trying the former reply first.

    Kind regards, Jeroen Peters

    eurekaindustries

    (@eurekaindustries)

    I had already tried to block the rights, putting 404 and then 504. It didn’t do anything. I just added the code to the config file, we’ll see. Thank you!

    Plugin Author jeroenpeters1986

    (@jeroenpeters1986)

    Okay, too bad the permissions did not help. I hope this new setting will work for you!

    Kind regards,

    Jeroen Peters

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.