[resolved] Forbidden - You don't have permission to access ... on this server (7 posts)

  1. Reluma
    Posted 2 years ago #

    Hi everyone,
    It's my first request of help. First of all, sorry for my bad english.
    I have recently migrate the website http://www.lasa.eu from windows server to linux server and I have a big problem with the images, as you can read in the title.
    I tried to modify the permission on folders in 755 and 777 but nothing works.
    I tried to modify the .htaccess file but nothing works.

    Any ideas?

  2. manavkumar
    Posted 2 years ago #

    @Reluma: Remove and upload all images again on your new Linux server for all items if its works then its fine otherwise you have to talk to your Linux hosting provider to change the permission setting on your server.

  3. Dave Naylor
    Posted 2 years ago #

    It's likely that the individual files themselves do not have public read access. The quick and easy way to change that is to perform this command having ssh'd to your site:

    find /path/to/your/wordpress/install/ -type f -exec chmod 644 {} \;

    If you're not comfortable with the command line, you'll have to manually change the permissions on the individual files the same way you changed the permission on the folders.

  4. Reluma
    Posted 2 years ago #

    The hosting provider don't know how to help me.
    Now I remove all the .htaccess files and the images appear,
    but the permalinks stop to work.

    Can you navigate the site?

  5. Dave Naylor
    Posted 2 years ago #

    Update your permalinks and see if WordPress recreates the .htaccess file for you.

  6. manavkumar
    Posted 2 years ago #

    i have navigate your site and everything is working fine even all the image shows properly.

  7. Reluma
    Posted 2 years ago #

    WP has recreated the .htaccess file.
    WE WIN!
    Now everything works.

    for some strange reason, after the migration to linux, the .htaccess file in the uploads folder contain this strings:

    Order deny,allow
    Deny from all

    I clean all and now it works!

Topic Closed

This topic has been closed to new replies.

About this Topic