Support » Fixing WordPress » Forbidden: you don’t have permission to access /blog/ on this server

  • Resolved agents2

    (@agents2)


    I tried to install wp in http://www.domain.com/blog

    Installation was successful – at first I could see the directory structure instead of the blog, so I followed my hosts directions to put a .htaccess in the root with specific commands to disable directory structure viewing..

    Now I get this:

    403
    Forbidden
    You don’t have permission to access /blog/ on this server.

    I searched the forums and found multiple problems and their solutions but none have worked for me, I tried changing permissions, I tried making an .htaccess file

    loading the /blog/index.php works fine. but when people type http://www.domain.com/blog , shouldn’t it go to index.php automatically?

    Thanks for your help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • whooami

    (@whooami)


    Member


    if you want help, please dont make people “look” for the url.

    http://www.stuartml.com/blog/

    what does your ROOT .htaccess have inside it? the one at the root of your site?

    Sorry about that!

    This is what the ROOT .htaccess has:

    Options Includes FollowSymLinks

    whooami

    (@whooami)


    Member


    and is there a index.html, index.php, or index.htm in the root of your site?

    index.html right?

    In your root .htaccess, put this:

    DirectoryIndex index.html index.php

    Yes. index.html, that is what currently shows if you visit http://www.stuartml.com

    I will try that, thanks

    whooami

    (@whooami)


    Member


    voila 🙂

    Wow, that works perfectly, thank you. How many others have this problem?
    whooami is a genius!

    Is it ok if I add you to my blogroll?

    As a side note, should I be worried about 777 permissions on my files? does that mean people can mess with them somehow?

    This just worked for me on a Windows install of Apache / WordPress. Any way WordPress could figure out whether php indexing is switched on when it is installed? This caused me a lot of frustration and I’d have never come up with this fix myself.

    This hasn’t fixed my problem – but it started happening as soon as I recompiled my PHP.

    The website declined to show this webpage
    HTTP 403
    Most likely causes:
    This website requires you to log in.

    I have a bad feeling that the PHP “make install” overwrote something, somewhere.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Forbidden: you don’t have permission to access /blog/ on this server’ is closed to new replies.