Support » Plugin: Spam protection, AntiSpam, FireWall, Cleaner by CleanTalk » Forbidden. Please enable JavaScript. Antispam service cleantalk.org.

  • Resolved SFBA Guy

    (@sfba-guy)


    CleanTalk was working fine. I don’t know what changed, but now whenever I try to submit my Contact Form 7, I see this message:

    *** Forbidden. Please enable JavaScript. Antispam service cleantalk.org. ***

    Javascript is enabled. All form types are enabled in CleanTalk’s settings.

    When CleanTalk is deactivated, the message doesn’t appear, and the form content is emailed to me as expected.

    I’ve tried deleting CleanTalk and reinstalling it. No change.

    What could be causing the problem?

    https://wordpress.org/plugins/cleantalk-spam-protect/

Viewing 15 replies - 1 through 15 (of 40 total)
  • Plugin Author Denis Shagy

    (@shagimuratov)

    Hi,

    Thank you for reporting us! Please send me your website URL I have to check our logs and test your contact form by myself.

    I tried it just now, and it seems to be working again. So I guess it’s resolved. Maybe a weird caching thing.

    Thanks anyway.

    Plugin Author Denis Shagy

    (@shagimuratov)

    Great! I think too it was caching issue.

    Thank you for keeping me up to date!

    Hi! I’m having the exact same issue — please can you tell me how to fix it!

    The website is photofayre.uk

    Contact form is on photofayre.uk/contact

    Thanks!

    Hello, adriannaik!
    Do you using some caching plugins?

    Hi,

    I have the same problem. It says “*** Forbidden. Please enable JavaScript. Antispam service cleantalk.org. ***” on the contact form (http://error404.fr/contactus/).

    I use a cache plugin, which is Photon from Jetpack, but it only caches images.

    Thanks!

    Hi!

    I have the same problem on my website. The contact form is located here : http://error404.fr/contactus/
    The contact form is created with Contact Form 7.

    I use Photon from the Jetpack plugin, which caches images.

    Thanks!

    wblondel, adriannaik
    Try to clear your browser cache and refresh page by pressing ctrl+r.

    Hi,,

    Thank you for your answer and sorry for the double post, I had to rewrite my post because of internet issues but it looks like it went through the first time x)

    Unfortunately, clearing the cache didn’t solve anything, I still have the same error :/

    EDIT : It works on Internet Explorer.. this is weird 😡

    Hi!

    I restarted my browser and now it works, thanks a lot!

    Hi, I just tried emptying the cache and refreshing and it worked. I have no caching plugins btw.

    Hopefully the issue is gone — but I had tried the same yesterday and it didn’t work.

    If it comes back again, I’ll be in touch =)

    We’re working on cache-independent solution, it will be done in one of the next releases.

    It seems, that i found the solution of the problem. Download this archive: https://downloads.wordpress.org/plugin/cleantalk-spam-protect.development.zip and reinstall our plugin, following this instruction:

    1. Go to WordPress Console -> Plugins.
    2. Deactivate, delete “Anti-spam by CleanTalk”.
    3. Go to WordPress Console -> Plugins -> Add new -> Upload.
    4. Upload and activate new version.

    Clear your browser cache, refresh page by pressing ctrl+r or ctrl+f5 then test contact form by entering email “stop_email@example.com” (you have to see, that message is blocked, without javascript error) and any other “normal” email (message has to be sent successfully). Please, let us know, does it helped you or not.

    Hi all!
    Try to use this fix: https://downloads.wordpress.org/plugin/cleantalk-spam-protect.zip. If ypu download it earlier – please, download again, because it’s content was changed. Reinstall it, following this instruction:

    1. Go to WordPress Console -> Plugins.
    2. Deactivate, delete “Anti-spam by CleanTalk”.
    3. Go to WordPress Console -> Plugins -> Add new -> Upload.
    4. Upload and activate new version.

    Clear your browser cache, refresh page by pressing ctrl+r or ctrl+f5 then test contact form by entering email “stop_email@example.com” (you have to see, that message is blocked, without javascript error) and any other “normal” email (message has to be sent successfully). Please, let us know, does it helped you or not.

    We use your Plugin at a community where members have to register.

    Some members get this message while registration:
    forbidden-please-enable-javascript-antispam-service-cleantalk

    but the have javasript enabled.

    Is this the same problem and should i use your fix?

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘Forbidden. Please enable JavaScript. Antispam service cleantalk.org.’ is closed to new replies.