Support » Plugin: Favicon by RealFaviconGenerator » Forbidden error for json file

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author phbernard

    (@phbernard)

    Hi Tony,

    I’m sorry you’re facing this issue.

    Which JSON file are we talking about? manifest.json? This is the Web App Manifest. As of today, only Android Chrome is using it. True: the official extension for this file is .webmanifest (not .json) and its MIME type is application/manifest+json. But unless your Web server already supports this, the .json extension is quite legit. It’s the one documented by Google for Android Chrome.

    But that doesn’t fix your problem 🙂

    Do you know why your Web server is raising this 403? Who/what did create this rule? What makes you think changing the location of the files might help? After all, you could well have a WP security plugin of some kind that thinks that all JSON files are bad and should be blocked.

    Tony42

    (@tony42)

    I’m not sure what rule is stopping it from being accessed. But if you could create an option to specify the install directory I could place the files in a directory that doesn’t have a rule preventing it. Is there a way I can change the install location of the icons and other files ?

    Plugin Author phbernard

    (@phbernard)

    Ok, I get it. I can’t add this option right now, but it’s on the TODO list.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Forbidden error for json file’ is closed to new replies.