Support » Plugin: Email Address Encoder » Forbidden

  • Resolved Piani

    (@webbmasterpianise)



    Whenever I try do anyting with this plugin its:

    Forbidden
    You don’t have permission to access /wp-admin/plugins.php on this server.

    Example:
    wp-admin/update-core.php?action=do-plugin-upgrade

    wp-admin/plugins.php?action=activate&plugin=email-address-encoder%2Femail-address-encoder.php&plugin_status=all&paged=1&s&_wpnonce=ebbadbab55

    Update or activate. Noting works and its only this plugin.

Viewing 9 replies - 16 through 24 (of 24 total)
  • Piani

    (@webbmasterpianise)

    I finally found the issue. I do not know is there is code or query that can be changed to prevent this but as the security plugin explains this might be the result. Still strange that no other plugin is stopped.

    But to other users that have this issue with All in one security plugin uncheck one firewall rule and it is solved for now.

    Additional Firewall Rules > Bad Query Strings

    “This feature will write rules in your .htaccess file to prevent malicious string attacks on your site using XSS.
    NOTE: Some of these strings might be used for plugins or themes and hence this might break some functionality.”

    Plugin Author Till Krüss

    (@tillkruess)

    Thanks for letting me know!

    same security plugin (all-in-one…) – same issue with email-address-encoder
    same solution has helped
    firewall/additional firewall rules/ bad query strings unchecked…

    Thanks @ piano and of course @ till

    crimeafrend

    (@crimeafrend)

    Piani, how did you manage to solve the problem? Faced absolutely with the same question. To weaken protection for the sake of work of 1 plug-in, this is not a very good solution.

    Same problem: updating ONLY the Email Address Encoder plugin the error appears
    Forbidden
    You don’t have permission to access /wp-admin/update.php on this server.

    Plugin Author Till Krüss

    (@tillkruess)

    @crimeafrend @webepc: He said the went to the “All in one security” plugin settings and then to “Additional Firewall Rules” and turned off the “Bad Query Strings” rule.

    The issue here is that the plugin blocks the word “encoder” and that’s why it’s not accessible.

    I confirm: the problem is just that!
    But once updated the plugin can you rehabilitate this setting or from problems of operation of the plugin?

    Plugin Author Till Krüss

    (@tillkruess)

    You can theoretically re-enable the setting, this plugin’s functionality won’t be affected.

    Plugin Author Till Krüss

    (@tillkruess)

    I’ve opened a support request, feel free to chime in: https://wordpress.org/support/topic/email-address-encoder-settings-inaccessible/

Viewing 9 replies - 16 through 24 (of 24 total)
  • You must be logged in to reply to this topic.