WordPress.org

Support

Support » How-To and Troubleshooting » For Those Still Having Trackback Issues

For Those Still Having Trackback Issues

  • Here’s what I did and it worked. Maybe it will work for you as well!

    Edit your execute-pings.php file (under wp-admin folder). Remember to back it up just in case. Change it to this:

    <?php

    require_once(‘../wp-config.php’);

    // Do Enclosures
    while ($enclosure = $wpdb->get_row(“SELECT * FROM {$wpdb->posts}, {$wpdb->postmeta} WHERE {$wpdb->posts}.ID = {$wpdb->postmeta}.post_id AND {$wpdb->postmeta}.meta_key = ‘_encloseme’ LIMIT 1”)) {
    $wpdb->query(“DELETE FROM {$wpdb->postmeta} WHERE post_id = {$enclosure->ID} AND meta_key = ‘_encloseme’;”);
    do_enclose($enclosure->post_content, $enclosure->ID);
    }

    // Do Trackbacks
    $trackbacks = $wpdb->get_results(“SELECT ID FROM $wpdb->posts WHERE CHAR_LENGTH(TRIM(to_ping)) > 7 AND post_status != ‘draft'”);
    if ( is_array($trackbacks) ) {
    foreach ( $trackbacks as $trackback ) {
    do_trackbacks($trackback->ID);
    }
    }

    // Do pingbacks
    while ($ping = $wpdb->get_row(“SELECT * FROM {$wpdb->posts}, {$wpdb->postmeta} WHERE {$wpdb->posts}.ID = {$wpdb->postmeta}.post_id AND {$wpdb->postmeta}.meta_key = ‘_pingme’ LIMIT 1”)) {
    $wpdb->query(“DELETE FROM {$wpdb->postmeta} WHERE post_id = {$ping->ID} AND meta_key = ‘_pingme’;”);
    pingback($ping->post_content, $ping->ID);
    }

    ?>

    Should do the trick for you. Oh yeah, I’m running 2.0.2.

    John
    http://www.houseofboyd.com

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘For Those Still Having Trackback Issues’ is closed to new replies.