WordPress.org

Forums

Ajax Load More
[resolved] fopen(), fwrite(), fread(), fclose() error after update (6 posts)

  1. alevalentini
    Member
    Posted 11 months ago #

    After updating the plugin I get this error:

    Warning: fopen([...]/wp-content/plugins/ajax-load-more//core/repeater/default.php): failed to open stream: Permission denied in [...]/wp-content/plugins/ajax-load-more/admin/admin.php on line 70
    Warning: fwrite() expects parameter 1 to be resource, boolean given in [...]/wp-content/plugins/ajax-load-more/admin/admin.php on line 71
    Warning: fread() expects parameter 1 to be resource, boolean given in [...]/wp-content/plugins/ajax-load-more/admin/admin.php on line 72
    Warning: fclose() expects parameter 1 to be resource, boolean given in [...]/wp-content/plugins/ajax-load-more/admin/admin.php on line 73

    I redownloaded manually the files and reuploaded them. Error stays.

    https://wordpress.org/plugins/ajax-load-more/

  2. dcooney
    Member
    Plugin Author

    Posted 11 months ago #

    Looks like there is an error in the file path.
    I'm out of town at the moment without access to the repository.

    Sorry about that, expect a fix Friday.

  3. alevalentini
    Member
    Posted 11 months ago #

    Thanks! :)

  4. dcooney
    Member
    Plugin Author

    Posted 11 months ago #

    Hey, Just had another look at this error and while it seems there is a slight error in the path to the template, it should still work.

    In the admin area, on the Repeater Templates page, do you see the green checkbox ('Write Access Enabled')?
    http://s.w.org/plugins/ajax-load-more/screenshot-2.png

  5. alevalentini
    Member
    Posted 11 months ago #

    Resolved changing permissions on plugin files and directories.

  6. alevalentini
    Member
    Posted 11 months ago #

    Thanks!

Reply

You must log in to post.

About this Plugin

  • Ajax Load More
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic