Support » Plugin: Email Log » fopen, fread, fclose warnings

  • Resolved mrmocha

    (@mrmocha)


    Hi,

    Every site I have this installed is showing the following warnings in the WP admin.

    Warning: fopen(/home/domain/public_html/wp-content/plugins/email-log-more-fields/email-log-more-fields.php): failed to open stream: No such file or directory in /home/domain/public_html/wp-includes/functions.php on line 4785
    
    Warning: fread() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4788
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4791
    
    Warning: fopen(/home/domain/public_html/wp-content/plugins/email-log-resend-email/email-log-resend-email.php): failed to open stream: No such file or directory in /home/domain/public_html/wp-includes/functions.php on line 4785
    
    Warning: fread() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4788
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4791
    
    Warning: fopen(/home/domain/public_html/wp-content/plugins/email-log-forward-email/email-log-forward-email.php): failed to open stream: No such file or directory in /home/domain/public_html/wp-includes/functions.php on line 4785
    
    Warning: fread() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4788
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4791
    
    Warning: fopen(/home/domain/public_html/wp-content/plugins/email-log-more-fields/email-log-more-fields.php): failed to open stream: No such file or directory in /home/domain/public_html/wp-includes/functions.php on line 4785
    
    Warning: fread() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4788
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4791
    
    Warning: fopen(/home/domain/public_html/wp-content/plugins/email-log-resend-email/email-log-resend-email.php): failed to open stream: No such file or directory in /home/domain/public_html/wp-includes/functions.php on line 4785
    
    Warning: fread() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4788
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4791
    
    Warning: fopen(/home/domain/public_html/wp-content/plugins/email-log-forward-email/email-log-forward-email.php): failed to open stream: No such file or directory in /home/domain/public_html/wp-includes/functions.php on line 4785
    
    Warning: fread() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4788
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /home/domain/public_html/wp-includes/functions.php on line 4791
    

    Any idea why?

    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Sudar Muthu

    (@sudar)

    Hello,

    This is really strange.

    Do you we have any add-ons installed or you have only the basic plugin installed?

    Hi,

    Just the basic one

    Plugin Author Sudar Muthu

    (@sudar)

    Have you at any particular point in time installed or tested any of the add-ons in the sites where you are getting these warnings?

    Also please let me know the version of Email Log plugin and WordPress version.

    Thanks.

    @mrmocha,

    (1) Are you using Apache server?

    (2) Also, could you share the existing file/folder permissions that you have set for files and folders under wp-content/ directory.

    Hi @sudar. I have not used any other addons, just the core plugin. I am using the latest versions of both the plugin and WordPress.

    Hi @mariadanieldeepak. It’s an Nginx server and folders are set to the recommended 755 and files are 644.

    It looks like if I delete and re-install the plugin it clears the errors. It will just take a while to do on lots of websites…

    I am experiencing the same issue. Using php 7.1 if that makes any difference. It is also somehow making WordPress think that I have 3 additional plugins to update. I guess I will try removing the plugin and reinstalling again.

    WARNING: wp-includes/functions.php:4785 - fopen(.../wp-content/plugins/email-log-more-fields/email-log-more-fields.php): failed to open stream: No such file or directory
    require_once('wp-admin/admin.php'), do_action('load-update-core.php'), WP_Hook->do_action, WP_Hook->apply_filters, wp_update_plugins, set_site_transient, do_action('set_site_transient_update_plugins'), WP_Hook->do_action, WP_Hook->apply_filters, AvailableUpdatesLogger->on_setted_update_plugins_transient, get_plugin_data, get_file_data, fopen
    WARNING: wp-includes/functions.php:4788 - fread() expects parameter 1 to be resource, boolean given
    require_once('wp-admin/admin.php'), do_action('load-update-core.php'), WP_Hook->do_action, WP_Hook->apply_filters, wp_update_plugins, set_site_transient, do_action('set_site_transient_update_plugins'), WP_Hook->do_action, WP_Hook->apply_filters, AvailableUpdatesLogger->on_setted_update_plugins_transient, get_plugin_data, get_file_data, fread
    WARNING: wp-includes/functions.php:4791 - fclose() expects parameter 1 to be resource, boolean given
    require_once('wp-admin/admin.php'), do_action('load-update-core.php'), WP_Hook->do_action, WP_Hook->apply_filters, wp_update_plugins, set_site_transient, do_action('set_site_transient_update_plugins'), WP_Hook->do_action, WP_Hook->apply_filters, AvailableUpdatesLogger->on_setted_update_plugins_transient, get_plugin_data, get_file_data, fclose

    Adding that the problem appeared after I upgraded WordPress to its latest version.

    @chamois_blanc yes I noticed the 3 additional plugin upgrades as well! I assumed it was unrelated, but now you mention it it must be related.

    I am only on php 5.6 though. Here are all the plugins I have installed (pretty much the same on all of our WP instances):

    Admin Columns
    Adminimize
    Advanced Custom Fields PRO
    Advanced Custom Fields: Image Crop Add-on
    Akismet Anti-Spam
    All In One WP Security
    Contact Form 7
    Contact Form 7 Honeypot
    Custom Post Type UI
    Duplicate Post
    Email Log
    Imsanity
    InfiniteWP – Client
    Instagram Feed
    MailChimp for WordPress
    Members
    Redirection
    Regenerate Thumbnails
    Revision Control
    SG Optimizer
    Simple History
    Social Warfare
    User Switching
    What The File
    Wordfence Security
    WordPress Importer
    WP Migrate DB
    Yoast SEO

    Something very odd going on.

    Plugin Author Sudar Muthu

    (@sudar)

    Thanks everyone for providing additional details and also confirming that you are able to replicate it.

    We are working on finding the fix on it asap.

    Expect a release soon with the fix for this.

    Plugin Author Sudar Muthu

    (@sudar)

    Our entire team is working on resolving this issue.

    Meanwhile are you seeing these warnings always in the WP admin in all pages or only when WordPress shows updates available or only just after getting WordPress updated?

    Hi,

    It’s mainly just on the plugin updates page. The rest of the admin areas have been fine.

    The errors were showing both before and after updates. When I tried deactivating the plugin sometimes it would break the install and just show the errors, no access to the rest of the page. Then if I deleted the plugin via ftp and added it back the normal way…everything would be fine.

    Plugin Author Sudar Muthu

    (@sudar)

    Hello all,

    We just released v2.2.0 of the plugin that fixes this issue.

    Kindly update the plugin to v2.2.0 and let us know if this fixes the issue.

    Thanks everyone for reporting the issue and for the patience.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘fopen, fread, fclose warnings’ is closed to new replies.