Support » Plugin: footnotes » Footnotes on WordPress pages

  • Resolved malcolmross42

    (@malcolmross42)


    I have been using Footnotes very successfully in my posts, but attempts to use Footnotes in pages fail. Am I doing something wrong? Is there a solution?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor pewgeuges

    (@pewgeuges)

    @malcolmross42

    This surprising behavior is not triggered by any built-in functionality as far as I know, as both are using the the_content hook.

    Please share your site URL if you don’t mind making it public, or alternatively your site health information privately using this form, for us to get a chance to try to investigate the problem, although I can’t guess where to look first, since this bug seems completely unknown.

    Plugin Contributor pewgeuges

    (@pewgeuges)

    Trying to figure the problem out meanwhile at my end, I’ve got Google to retrieve:

    https://wordpress.org/support/topic/the_content-filter-not-called/

    This was fixed by changing a priority level, so it might be worth a try to open the “Scope and priority” tab of Footnotes’ dashboard and changing the priority of the_content.

    Another track is looking into the theme’s page template, whether the `$content = apply_filters( ‘the_content’, $content ) part is skipped somehow. The quickest way to assess this is temporarily switching to <em>Twenty Twenty-One</em>.

    Sorry for not responding to your questions: While something <em>is</em> wrong, it isn’t necessarily a matter of <em>doing</em> it wrong. Sadly I don’t have any ready-to-use solution to fix this unexpected and unprecedented outage.

    Routinely one would also check for a plugin conflict by deactivating all other plugins to see if the bug persists.

    We’re sorry for not having any solution ready since the issue itself did never come up in this form until now. Formerly Footnotes did not work on <em>category pages,</em> but that is probably unrelated. Fixing this required adding the same filter to term_description as is added to the_content.

    That leads however to the assumption that you might have footnotes on particular pages not using any hook supported up to now?

    Thread Starter malcolmross42

    (@malcolmross42)

    @pewgeuges, I owe you an apology. I asked if I was doing something wrong, and I was. I am new at WordPress, and I have discovered that I was apparently confusing pages with templates (I don’t know how this happened). Anyway, my pages are now recognised as pages, and the footnote plugin works as it should. I am sorry to have caused you unnecessary trouble.

    Plugin Contributor pewgeuges

    (@pewgeuges)

    Hi @malcolmross42,

    No problem at all! I’m very glad that you got to solve the issue. Also I apologize for seeing only now that I’d messed up my previous reply in multiple ways. But given that you have managed to fix the bug, there’s no need to re-post the above.

    Best of luck, and be sure to keep reaching out should you require any assistance in setting up Footnotes on your website. We’re always happy to help. Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.