Support » Plugin: Easy Footnotes » Footnote Numbers Don’t Match

  • Resolved GarnetHGB

    (@garnethgb)


    I am working on my first post and don’t have it published, so I cannot provide a link. However, I did link to a brief screenshot of my undesirable result.

    The word I am footnoting is “Kalahome”, which is properly footnoted; the sentence just beneath it that begins “Mr T …” is the beginning of what will be a very long essay. As I said, I am just starting this post.

    So “Kalahome” is my first footnote attempt. And please note that I do NOT have the option “Hide Footnotes after post content” selected, yet there is that “2” immediately above the Footnotes label that ─ when hovered over ─ displays the text I want footnote “1” linking to.

    Yet I have not begun a second footnote ─ I have not proceeded that far yet in my post.

    As well, you can see that just beneath the Footnotes label is the “1.” with the directing red arrow that I do indeed want displayed; but the plain-text “2.” that is just beneath that is the start of the footnote information that’s also being displayed by the live-link “2” just above the Footnotes label.

    Maybe we aren’t supposed to have exceptionally long footnotes? ─ I probably have as many as 40 lines of text with five breaks for paragraphs within that text as my footnote.

    And / or maybe I’m just not using the proper footnote coding? I can see that the footnote numbers are generated with [efn_note][/efn_note], and we don’t seem to need to insert the footnote number between those enclosures.

    But what about the text of information that we want the footnote to link to? Is it the very same code? ─ that is, [efn_note] just ahead of the first word of the very long footnote text, and then [/efn_note] immediately after the final word?

    I have deleted the Easy Footnotes plugin twice, and even run WP-Optimize after the second deletion, before uploading Easy Footnotes a third time. And the only adjusting I did in the options area this third time was to tick the “Insert Easy Footnotes Label” box ─ I never touched the “Hide Footnotes after post content” option, so there shouldn’t be a live-link “2” (nor any other live-linked number) that ─ when hovered over ─ is displaying the footnote information.

    But I can’t seem to be rid of it.

    I’m using the Weaver Xtreme theme, and the Classic Editor of WordPress.

    I don’t know if I’ve adequately explained my problem ─ I hope I haven’t detailed so much that this has become too bewildering to understand.

    I’m wiped out for today, so I’m going to shut this down and worry on it tomorrow. Maybe there isn’t a solution ─ perhaps my specific website setup is one of those for whom the plugin is simply incompatible.

    I’m willing to accept that, so please don’t knock yourself out trying to respond to this confusion as I have presented it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jason Yingling

    (@yingling017)

    There shouldn’t be any issue with really long footnotes.

    The way to use the footnote is:

    This is an example[efn_note]This is the footnote.[/efn_note] of a sentence with a footnote.

    Which would output like this on the front-end.

    “This is an example1 of a sentence with a footnote.”

    Where the 1 would hover and show “This is the footnote.”

    If that’s what you’re using and not getting the proper results do you mind sending me a snippet of the code from your editor so I can see specifically how you’re entering the [efn_note][/efn_note] shortcode?

    This is how I have the footnote number itself appear in the working text, Jason:

    * The dignity of Kalahome[efn_note]1[/efn_note] is similar to that of Prime Minister.

    I of course placed the digit “1” between the open and closing bits of code.

    Then at the bottom of the post where I wanted the reader to be sent to when the footnote “1” was clicked on, I placed the opening string of code in front of the very first word of the explanatory text like this:

    [efn_note]From: Family Politics in Nineteenth Century Thailand* by David K. Wyatt

    And at the very end of the long footnote explanation, I finished the last line of text like this:

    …and there were three classes of distinction (i.e., Gold, Silver, and Regular).[/efn_note]

    That concluded the actual footnote. And in this instance, the only plugin option I ticked was the one identified as “Insert Easy Footnotes Label”.

    I had deleted the plugin since my first comment, so this was a fresh installation of it, and the result was the same as in my earlier screenshot.

    Since I first made my original comment a week ago, I haven’t just been doing without footnotes. I did some research and found that I can use the following code to create the numerical footnote after whatever word or phrase I want to explain ─ I’ll use my example above:

    * The dignity of Kalahome[1] is similar to that of Prime Minister.

    And then I manually link to the footnote text by adding this at the start of the actual footnote:

    [1]From: Family Politics in Nineteenth Century Thailand* by David K. Wyatt

    I have to insert the digit “1” myself.

    Then with every subsequent footnote, I just keep bumping the count one figure higher, and change every one of the digits in the code accordingly.

    I haven’t been happy with just the tiny digit “1” to mark a footnote, so the procedure I have been using allows me to use whatever footnote indicator I like. I use “Note 1”, “Note 2”, etc. instead of just a digit, for it makes the footnote far more obvious.

    It’s been working so far. Clicking on the “Note 1” or “Note 2” and so on that precedes an actual footnote text will throw the reader back up to where the footnote indicator is in the article ─ or at least, it brings the reader close enough to that starting point. It’s not perfect, but it is a far cry from forcing the reader to have to manually scroll all the way back to where he or she had left off.

    I can live with this.

    Plugin Author Jason Yingling

    (@yingling017)

    The way the plugin works every time you use [efn_note]Footnote content here.[/efn_note] it outputs a numbered superscript element. You don’t have to do any numbering yourself and it’ll automatically put the arrow back up to the proper footnote.

    If you don’t like the style of the superscript you can target that element with CSS to change it up however you like too.

    .easy-footnote sup {
      font-size: 16px;
    }

    That’s an example that would make the font 16px.

    It doesn’t seem to matter even when I don’t supply my own footnote digit.

    Even with the footnoted word or phrase marked like this (the word “Kalahome” in this case)

    * The dignity of Kalahome[efn_note][/efn_note] is similar to that of Prime Minister.

    I still end up with the actual footnoted text showing up in like my screenshot.

    I even tried previewing the post in a browser that I do not ever use to access my website in. I prefer working in Firefox, but I’ve got an AVG Secure Browser that I once somehow got downloaded along with my Antivirus Free, and which I have never bothered to try and be rid of. The footnotes come out exactly as they do in the screenshot.

    I promise that I never supplied my own numeral this time ─ I let the plugin do it all. I just used the two sets of [efn_note][/efn_note] code. The first set as shown in the blockquote; and the second set separated in order to sandwich all the text of my actual footnote.

    Plugin Author Jason Yingling

    (@yingling017)

    Your [efn_note][/efn_note] call should contain the text you want as the footnote text.

    Like this:

    * The dignity of Kalahome[efn_note]From: Family Politics in Nineteenth Century Thailand...[/efn_note] is similar to that of Prime Minister.
    
    Mr. T, the Consul of Hamburg, accompanied by a friend, were my travelling companions, buy there were in another boat.

    Which would then output something like:

    * The dignity of Kalahome1 is similar to that of Prime Minister.
    
    Mr. T, the Consul of Hamburg, accompanied by a friend, were my travelling companions, buy there were in another boat.
    
    Footnotes
    
    1. From: Family Politics in Nineteenth Century Thailand...

    Well, that worked!

    Even as I was trying it out, the method seemed to defy logic in that I just could not accept that there did not need to be a second set of footnote codes at the base of the article, so I wasn’t really expecting to see a successful result.

    What annoys me now is why everyone before me who used the plugin apparently immediately recognized how to use it, but I failed to.

    Consider this issue resolved, Jason!

    Plugin Author Jason Yingling

    (@yingling017)

    No worries, glad we got it worked out!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.