Support » Fixing WordPress » Footer Text Decoration

  • Hi,

    My footer shows with an underline on my home page on Safari 5.1 even though I set the text-decoration to none. It looks as it should on other pages and Firefox. My guess is that it might have to do with the nggallery on the home page, but really not sure. OSX Snow Leopard.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Drew Jaynes

    (@drewapicture)

    WordPress Core Developer

    Can you provide a link to your site so we can take a look and help you diagnose the problem?

    Drew Jaynes

    (@drewapicture)

    WordPress Core Developer

    There is a text-decoration: underline; attribute set for a:-webkit-any-link via the user agent stylesheet coming from your browser’s default settings.

    I suggest placing the <a href> link inside the <footer> tags and creating a Safari-specific body class for <a href> links to override the browser default, e.g. body.safari a { text-decoration: none; }

    Hope that helps.

    That fixed it. Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Footer Text Decoration’ is closed to new replies.