Support » Plugin: Best Image Gallery & Responsive Photo Gallery - FooGallery » FooGallery disabled my site and WP login !

  • Resolved sadhaka

    (@sadhaka)


    I couldn’t view my WordPress site – or even log in to admin. I looked at my PHP error logs and saw countless errors saying:

    PHP Fatal error: require_once(): Failed opening required '/[path]/wp-content/plugins/foogallery/includes/constants.php' (include_path='.:/[path]/php71/lib/php') in /[path]/wp-content/plugins/foogallery/foogallery.php on line 28

    This of course immediately implicated the FooGallery plugin, so I FTPd in and renamed the plugin folder.

    Bingo – the site was once again visible and I could log in.

    Looking at the foogallery.php file mentioned in the error logs I noticed that there were many non-standard characters, which my text editor BBEdit renders as upside-down question-marks.

    The line 28 in the foogallery.php file is:

    require_once FOOGALLERY_PATH . 'includes/constants.php';

    … but there is no includes directory !

    My site and login was working fine the other day so I have no idea what has happened to this plugin. All I do know is that it broke my site – badly!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter sadhaka

    (@sadhaka)

    version is 1.6.1 btw

    Plugin Author bradvin

    (@bradvin)

    hi – it seems your plugin zip file is somehow corrupt? I checked the lastet zip from https://downloads.wordpress.org/plugin/foogallery.zip and it contains the “includes” folder.

    I would like to know more about the special characters too. There should be no special characters apart from the standard new line chars etc. Please can you zip up your current foogallery folder and email it to me : brad @ fooplugins . com

    so I can investigate – thanks

    Hi sadhaka,

    We haven’t heard back from you on this so I’m assuming you were able to download and reinstall the latest version and will mark this issue as resolved.

    If you are still having issues please feel free to reopen this ticket so we can assist you further.

    Thread Starter sadhaka

    (@sadhaka)

    You may not assume that! The problem persists!

    I followed Brad’s instructions above and emailed the zipped foogallery folder, but I’ve heard nothing in return.

    As I also mentioned in my email, the problem also affects FooBox Premium, not just FooGallery.

    Hi @sadhaka,

    Thanks for replying. We’ve had no other reports of this issue that I’m aware of so it very much sounds like it may be something to do with your web hosting.

    Would you please send an email to support.foogallery@fooplugins.com and include the URL to this support ticket in that email:

    https://wordpress.org/support/topic/foogallery-disabled-my-site-and-wp-login/

    I’ll then work directly with you to see if we can identify what is happening and get it resolved for you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘FooGallery disabled my site and WP login !’ is closed to new replies.