Support » Plugin: Best WordPress Gallery Plugin – FooGallery » foogallery.css sometimes not loaded

  • Resolved saturnusdj

    (@saturnusdj)


    Sometimes the galleries do not load correctly. Refreshing the page results in the galleries being loaded correctly. This phenomenon seems to happen when the page was not opened for a while, maybe 30 minutes. Just refreshing the page continuously will not result in this problem. This problem was reported by two visitors, but only the last few days I am seeing it a lot myself.

    I did the following test: Save the page with and without the problem. In the downloaded files I can see that foogallery.css is missing when the problem occurs. Firefox Console does not show errors.

    The four galleries are Justified, default sorting.

    Changes over the default settings:
    * Enabled: HTML Cache
    * Default Gallery Template: Justified Gallery
    * Default Gallery Settings: set
    * Enabled: Hide Gallery Template Help
    * Enabled: Hide Classic Editor Button
    * Default Retina Support: 2x
    * Disabled: Custom Ready Event (enabling does not solve the problem)
    * Enabled: Force HTTPS
    * Custom Stylesheet used (not using it does not solve the problem)

    Tried:
    * Clear HTML Cache
    * Clear CSS Cache

    A few days ago, I disabled the WP Caching plugin.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Support elviiso

    (@elviiso)

    Hi @saturnusdj

    After testing this extensively using different browsers and multiple devices, the galleries added to that page are always loading properly as they should without any issue or without having to reload the page again.

    Could you kindly clear your browser’s cache and then try it out again and let me know if it will still be happening on your end?

    Thanks in advance for that.

    Kind regards,
    Elvis.

    • This reply was modified 10 months, 1 week ago by elviiso.
    Thread Starter saturnusdj

    (@saturnusdj)

    Hey @elviiso,

    Thanks.
    I tried Firefox, Firefox private window, Microsoft Edge, iPhone Safari, iPad Safari and seen it happening on all of them. However as noted it seems like for ~30 minutes there have to be no visitors for it to occur.

    Remember your post @ https://wordpress.org/support/topic/force-column-amount-from-6-to-3-2-1-skipping-4-and-5/#post-14613844? I think that’s when it happened to you too.

    Thread Starter saturnusdj

    (@saturnusdj)

    In another try I found that foogallery.css was present while the problem happened.

    Plugin Support elviiso

    (@elviiso)

    Hi @saturnusdj

    If, as you say, the site needs not to have any visitors for 30minutes for it to occur, it’s going to be a tall order to try to test this out on that page from our end!

    What you can do is to create a private page whose link is not added to the site and add those same galleries on that page too then share the URL link to that page.

    Thanks in advance for doing so.

    Kind regards,
    Elvis

    Thread Starter saturnusdj

    (@saturnusdj)

    Hey @elviiso ,

    The ‘good news’ though is that the site barely has visitors at this moment.
    I tried a full reinstall of the plugin, including Foobox as well. The problem still occurred.

    So, I made marcuspasveer.com/test-new/ with different galleries, but same media as the homepage and marcuspasveer.com/test-old/ that uses the exact same galleries as on the home page.

    Thanks!

    Thread Starter saturnusdj

    (@saturnusdj)

    I tried the pages. Both test pages came up fine, but the frontpage/home had the problem again…

    I removed the page (home) and made a new one with same content. ‘New’ home. Let’s see.

    • This reply was modified 10 months, 1 week ago by saturnusdj.
    Thread Starter saturnusdj

    (@saturnusdj)

    (Sorry editing the last post is time limited.)

    That also did not work. This is really not good and I have no clue anymore what to try. If you know how to do debugging, please let me know.

    Thread Starter saturnusdj

    (@saturnusdj)

    Another update.
    When I give .all-header opacity 0.5, the following becomes visible:

    https://i.ibb.co/CnjNJkN/Screenshot-2021-07-12-Marcus-Pasveer-Content-creator-for-agribusinesses.png

    Galleries 1-4 are placed underneath the header, covering each other. Top to bottom: 4,3,2,1.

    I tried another theme, same thing. A visitor reported this problem.

    • This reply was modified 10 months, 1 week ago by saturnusdj.
    Plugin Author steveush

    (@steveush)

    Hi @saturnusdj,

    I managed to get the issue to occur. It seems you are having HTTP/HTTPS issues. In the console the first error I see is the following:

    Mixed Content: The page at 'https://marcuspasveer.com/' was loaded over HTTPS, but requested an insecure stylesheet 'http://18.169.25.212/wp-content/plugins/foogallery/extensions/default-templates/shared/css/foogallery.css?ver=2.0.39'. This request has been blocked; the content must be served over HTTPS.

    I’m not sure why this would be happening but we do have an option under FooGallery > Settings > Advanced called Force HTTPS. Please enable this setting, clear all your caches and test again.

    Thanks
    Steve

    Thread Starter saturnusdj

    (@saturnusdj)

    @steveush

    Thanks. Glad to hear that it happened.
    Which browser are you using?

    The mixed content error happened a lot a while ago. I think because the domain name was linked to the ip after setup of WordPress etc. Therefore I replaced all occurrences of the ip address in the database (via WP phpMyAdmin) and WordPress settings with the domain name, including https where needed. After that I never saw the mixed content error again, in Firefox.

    As mentioned in the topic start Force HTTPS was enabled. After reinstall it was not enabled, but I enabled it again now. It did not help.

    In Microsoft Edge Console, I now found this:
    Item foogallery.min.css:1. Error: Failed to load resource: net::ERR_CERT_COMMON_NAME_INVALID. However the suggested solutions for that do not make sense. I am opening a topic on the Bitnami forum, see if they have an idea as at this point I am not sure if it is a FooGallery problem, despite this only happening with FooGallery.

    Plugin Author steveush

    (@steveush)

    Hey @saturnusdj,

    It has been a while since I had to deal with certs but I think the net::ERR_CERT_COMMON_NAME_INVALID might be popping up because the common name for your cert would be your domain name, marcuspasveer.com, however you are attempting to load assets using a direct IP address over HTTPS. The IP is not the common name in the cert and so it gets rejected as invalid.

    Thanks
    Steve

    Thread Starter saturnusdj

    (@saturnusdj)

    @steveush

    Thanks!

    That makes sense, however where would the HTTP+IP (that you mentioned earlier) be called from? The IP address is not in the WordPress database anymore according to phpMyAdmin. On the file system level it was found in:

    Binary file /opt/bitnami/mysql/data/ib_logfile0
    Binary file /opt/bitnami/mysql/data/binlog.000013
    Binary file /opt/bitnami/mysql/data/undo_002
    Binary file /opt/bitnami/mysql/data/binlog.000010
    Binary file /opt/bitnami/mysql/data/ib_logfile1
    Binary file /opt/bitnami/mysql/data/bitnami_wordpress/wp_postmeta.ibd
    Binary file /opt/bitnami/mysql/data/#ib_16384_1.dblwr
    Binary file /opt/bitnami/mysql/data/binlog.000012
    Binary file /opt/bitnami/mysql/data/#ib_16384_0.dblwr
    Binary file /opt/bitnami/mysql/data/binlog.000009
    Binary file /opt/bitnami/mysql/data/undo_001
    /opt/bitnami/apache2/logs/error_log
    /opt/bitnami/apache2/logs/access_log:

    So not even in files like wp-config. I do not know why it is found in the wp_postmeta file. Maybe MySQL keeps old data in the file that is not used in the database.

    Concerning the Apache logs, it seems (hack/crawl) bots try to access parts of the site via the ip address. And the WordPress wp-cron task opens things via the ip too. Not sure how that works. I followed https://thewp.pro/tutorials/wp-cron/ to get rid of it.

    In any way…I do not understand what could make it so that resources for visitors would be loaded over the ip address and/or non-https. The network interface does not even have the public ip address assigned to it.

    I removed some apache mod_pagespeed stuff just now, let’s see if that does any good.

    Plugin Author bradvin

    (@bradvin)

    @saturnusdj also clear the css optimization cache from the FooGallery settings page to ensure the css path cache is cleared.

    You will then need to visit the gallery page in order to store a new css path with the correct details

    Thread Starter saturnusdj

    (@saturnusdj)

    Sadly the issue remains.

    Plugin Author bradvin

    (@bradvin)

    look at your page source, the css is loading from https://marcuspasveer.com/wp-content/plugins/foogallery/extensions/default-templates/shared/css/foogallery.min.css which is correct. The page https://marcuspasveer.com/ loads fine for me with no need to refresh

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘foogallery.css sometimes not loaded’ is closed to new replies.