Support » Plugin: Best Image Gallery & Responsive Photo Gallery - FooGallery » FooGallery Admin Links Return Error

  • Resolved heffegg

    (@heffegg)


    Clicking on any link for FooGallery Admin in WordPress Dashboard returns the following error: “The page you requested could not be found. Try refining your search, or use the navigation above to locate the post”

    I select FooGallery –> Galleries
    Link is: https://mydomain.com/wp-admin/edit.php?post_type=foogallery

    I have cleared all caches, disabled plugins and all other obvious solutions. Checking in Chrome Dev tools shows a 404 error and that’s all.

    FooGallery plugin version: 1.10.3
    Wordpress version: 5.7

    The Gallery worked a week ago, now I get this post error. I am not aware of any changes since last time it was accessed. Existing Galleries still show on the site. I need to Edit one and this happens.

    Any solution would be much appreciated. ELSE… I change to another gallery plugin.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support elviiso

    (@elviiso)

    Hi @heffegg

    Could you kindly go through this guide and try to implement this fix and let us know how it goes? Thanks in advance.

    https://www.wpbeginner.com/wp-tutorials/how-to-fix-wordpress-posts-returning-404-error/comment-page-2/

    Kind regards,
    Elvis

    Thread Starter heffegg

    (@heffegg)

    Thank you.
    I’ve followed directions in the link provided. Checked the .htaccess file
    Temporarily removed it to let wordpress create a new .htaccess file
    Checked that the post_type foogallery exists in the database.
    Permalinks are set to: /%postname%/

    All pages, posts and FooGallery galleries work as expected.
    The only thing NOT working is FooGallery admin links from WP-Admin dashboard.
    Plugins currently installed:

    FooGallery 1.10.3
    Printful Integration for WooCommerce 2.1.21
    Super Progressive Web Apps 2.1.8
    UpdraftPlus – Backup/Restore 1.16.53
    WooCommerce 5.1.0
    WooCommerce Stripe Gateway 5.0.0
    Wordfence Security 7.5.2
    WP Fastest Cache 0.9.1.6

    Any other suggestions would be gratefully accepted, chose your plugin for the Custon URL option so that gallery images can link to products in WooCommerce.
    It’s an excellent feature.

    Thread Starter heffegg

    (@heffegg)

    Theme: Divi 4.9.3

    Plugin Support elviiso

    (@elviiso)

    Hi @heffegg

    We suspect that this issue is being caused by Freemius. FooGallery uses Freemius under the hood to handle all plugin licensing and payments.

    We would like to kindly ask you to delete the Freemius account and then activate it again after that and see if it will help.

    To delete the account, once on the WordPress admin dashboard, kindly navigate to FooGallery -> Accounts then click on the “Delete Account” option similar to the one shown in this image:https://prnt.sc/115i9z0

    You can also get to the Freemius debug page by going to wp-admin/?page=Freemius in the backend then clicking delete all accounts.

    Kindly try this and let us know how it goes.

    Kind regards,
    Elvis

    Thread Starter heffegg

    (@heffegg)

    Hi,
    No links in FooGallery admin work, so I cannot go to accounts or anything else.
    Trying to connect to wp-admin/?page=Freemius returns the following:
    “Sorry, you are not allowed to access this page.”

    I am logged in as the Site Administrator.

    I’m going to give up now and switch to another Gallery.

    Thank you for your assistance, I would really like to get to the bottom of this but my client wants the site working ASAP.

    Plugin Support elviiso

    (@elviiso)

    Hi @heffegg

    Could you kindly give us just a few hours to look into this issue, including why you are getting that message when you try to view your Freemius account and we’ll get back to you with a fix? Thanks in advance.

    Hope to hear from you soon.

    Kind regards,
    Elvis

    Plugin Support elviiso

    (@elviiso)

    Hi @heffegg

    Thanks for your patience.

    Regarding this issue, as I mentioned earlier, we highly suspect that it’s caused by Freemius, and deleting the current account will most likely fix this issue.

    To get to the Freemius debug page go to /wp-admin/?page=freemius in the backend of your WordPress site(the link must be in lowercase to avoid getting that message you received earlier) then clicking delete all accounts button shown in this image: https://prnt.sc/1175j6c

    Alternatively, you can use the Freemius fixer plugin to resolve this issue. Here’s a guide on how to install and use the plugin to resolve this issue: https://fooplugins.com/documentation/foogallery/troubleshooting-foogallery/freemius-errors/

    Kindly try this and let us know how it goes.

    Kind regards,
    Elvis

    • This reply was modified 4 weeks, 1 day ago by elviiso.
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.