Support » Plugin: FooGallery Image Gallery - Responsive Photo Gallery » Foo gallery won’t center align

  • Resolved guillaumepierson

    (@guillaumepierson)


    Hello, I’m trying to improve my website by using foo galleries but I run into this issue where they don’t want to center align despite having the right setting.
    Even worse, they will sometimes align then I’ll get off the website to come back the next day and have the galleries on the left again.

    Anyone had this issue?
    Thanks for your answer.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support phillcoxon

    (@phillcoxon)

    Hi @guillaumepierson,

    This sounds like there may be a conflict with some CSS in your theme.

    @steveush – are you able to take a look at this and give us some feedback?

    Thanks for the answer.
    Some days it’s displayed the right way and some days it’s not!
    As I’m writing this images are on the left and not displayed in a gallery.

    Plugin Contributor steveush

    (@steveush)

    Hi,

    The issue here is one with HTTP and HTTPS on your site. If you check the developer console there are a few errors relating to this problem but in short your site is being loaded with mixed content. What this means is the page itself is saying it is HTTPS secure while some of the assets being loaded into the page are being supplied as HTTP unsecure. Most modern browsers will block all unsecure content from loading at all, in this case the foogallery CSS stylesheets as well as some images are all being delivered as HTTP and are therefore not being loaded by the browser. This results in the alignment issue as there is no CSS in the page at all to style the galleries.

    Once this mixed content issue is resolved the gallery issues should also disappear. One thing you can try as a temporary work-around is to enable the FooGallery > Settings > Advanced > Force HTTPS option.

    Thanks

    Big thanks for the detailed answer! I’m gonna try this and let you know if it worked. 🙂

    edit: Just enabled force https, it seems to still be the same?
    I also noticed there’s an alert about thumbnails generation but can’t figure out where that comes from exactly.

    Plugin Contributor steveush

    (@steveush)

    Hi @guillaumepierson,

    It is still showing the stylesheets as being delivered as HTTP. Could you please try going to the FooGallery > Settings > General tab and then clicking both the Clear Gallery HTML Cache and the Clear CSS Optimization Cache buttons. Also just to make 100% sure all caching is cleared, if you use a plugin like Autoptimize please clear its cache as well.

    Let me know if that resolves it.

    Thanks
    Steve

    Ohh yes at the moment it works! Thx so much dude, I spent time on those pages and seeing it wasn’t displayed right was quite sad.
    Hope it stays like that now 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.