Support » Plugin: Fonts Plugin | Google Fonts Typography » Fonts not appearing in sidebar widgets

  • Resolved Maria Grace

    (@maria-grace)


    The fonts are all appearing properly in the content, but not in the sidebar. I followed the suggestion of changing the author name on the child them that came up in a previous topic, but that did not fix the problem.

    I am using Graphene theme and all files are up to date.
    I have Courgette set for the widget titles and Lato for the text. I see them in the customizer on the back end, but not when I bring up the site while not logged in.

    Any assistance you could provide would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter Maria Grace

    (@maria-grace)

    Additionally, I tried using the font block and the font in the block did not change. You can see the post here: https://randombitsoffascination.com/2021/05/13/a-brief-history-of-blueancient-blue-pigments/

    The first block in the post is the font block and the font displayed is definitely not Parisienne as selected in the font block. The font shows up correctly in the editing window.

    Once again, any assistance you can provide would be appreciated.

    Plugin Author DannyCooper

    (@dannycooper)

    Hi @maria-grace,

    Thanks for the bug report! We’ve just released an update that should cover this (2.5.8).

    Let me know if I can help with anything else.

    Thanks

    Thread Starter Maria Grace

    (@maria-grace)

    @dannycooper Thank you for the update.

    I have installed it, deleted the cache and reset the fonts in the customizer. The fonts still do not appear in the sidebar. Similarly, the fonts from the plugin’s Google Font block do not appear in published posts. I can see them in the editor prior to publishing.

    Any assistance would be appreciated. Thank you.

    Plugin Author DannyCooper

    (@dannycooper)

    Hi @maria-grace,

    That’s strange, do you use a child theme with the Graphene theme?

    Thread Starter Maria Grace

    (@maria-grace)

    Yes, I am using a child theme.

    Thank you.

    Plugin Author DannyCooper

    (@dannycooper)

    For the child theme to work with the compatibility code we use for the Graphene theme, the ‘Author:’ field in style.css must match the parent theme:

    Author: Graphene Themes Solutions

    https://themes.trac.wordpress.org/browser/graphene/2.8.4/style.css

    • This reply was modified 6 months, 1 week ago by DannyCooper.
    Thread Starter Maria Grace

    (@maria-grace)

    Thank you for the advice. I changed the author of the child theme to match the parent theme. The sidebar fonts appear to be working now, so first problem solved, thank you very much!

    Unfortunately, the Google Font blocks from the plug in still do not seem to be working. The first paragraph of this post https://randombitsoffascination.com/2021/05/13/a-brief-history-of-blueancient-blue-pigments/ is set to Parisienne font in the font block. It shows up in the editor that way, but not upon publication.

    Any further assistance with this issue would be greatly appreciated.

    Thank you.

    Plugin Author DannyCooper

    (@dannycooper)

    Is Parisienne a font you have uploaded yourself?

    Thread Starter Maria Grace

    (@maria-grace)

    No, it is a standard Google Font.

    Thank you.

    Plugin Author DannyCooper

    (@dannycooper)

    Hi @maria-grace,

    This looks like a caching/optimization issue to me. Could you temporarily disable WP Optimize and any other related plugins you have so we can investigate further?

    Thanks

    Thread Starter Maria Grace

    (@maria-grace)

    I have disabled Jet Pack Boost, WP-Optimize and Fastest Cache.

    Thank you for your assistance @dannycooper .

    Thread Starter Maria Grace

    (@maria-grace)

    @dannycooper

    With those three plugins turned off, the fonts display as expected.

    With Fastest Cache enabled, the fonts appear as they should.
    With JetPack Boost Enabled, the fonts appear as they should.
    With JetPack Boost and Fastest Cache enabled, the foots appear as they should.

    With Optimizer on by it self or with the others, the fonts do not display.

    I will leave then three disabled for the time being. I hope this was of some use.

    Thank you for the continued assistance.

    Plugin Author DannyCooper

    (@dannycooper)

    Hi @maria-grace,

    That would suggest that there is some kind of compression/caching/rewriting being performed by WP-Optimize that is causing a problem.

    It’s possible that the plugin might have a built-in cache that you can clear.

    Thread Starter Maria Grace

    (@maria-grace)

    I have reactivated WP-optimize and cleared the minify cache as soon as it was activated. The side bar font are still working, but the plugin font block does not.

    Thank you for your continued assitance.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Fonts not appearing in sidebar widgets’ is closed to new replies.