Support » Plugin: Admin Custom Login » Fonts No Longer Working

  • Inndesign

    (@inndesign)


    Since the latest update to version 3.1.1, the login panel fully defaults to Times Romans even though Open Sans is selected for all font options under Font Settings. This is true for any website currently installed. Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Netspark

    (@netspark)

    I can confirm that. Since latest update, the font setting is no longer working. Maybe there’s a problem with the javascript API that does the font loading in the background.

    Plugin Author weblizar

    (@weblizar)

    Hi @netspark & @inndesign

    The font setting is working on our site. Can you please send a screenshot of that or link to your login page.
    It will help us find out if the font setting is working or not on your end.

    Here is an example of a screenshot. it shows the font family, color and size of text. https://imgur.com/remQ47c

    Thanks and most welcome

    • This reply was modified 1 year ago by weblizar.
    Inndesign

    (@inndesign)

    Attached is the proof requested for @weblizar. Results are the same on every current version WordPress installation I tried Admin Custom Login on: http://inndesign.com/font-failure.jpg

    I also wanted to point out the <p id=”lable_login_input”> is spelled wrong. The correct spelling is ‘label’.

    At the bottom of the Login Form Setting panel, the last two sentences, one has two periods after the word ‘panel’.

    Under Logo Settings, under the Logo Image Width and Logo Image Height sliders, please add in italic “Use your left and right arrow keys to select the exact number“. I have been trying to get the right numbers for a couple of years now, and just figured out the arrow keys allows me to select the exact pixel value. The slider is just too hard to use for single-digit selection.

    Under the Help and Support tab, the text under Rate Us is incorrect grammar. It should read: “If you enjoy using our Admin Custom Login plugin and find it useful, then please consider writing positive feedback. Your feedback will encourage us to continue development and provide better user support.”

    Also, under that text on the same panel, the title should read: “Share With Us Your Suggestions” followed by the corrected grammar “If you have any suggestions or features in mind please share your thoughts with us. We will try our best to add them to this plugin.”

    Under “Language Contribution” The word “Plguin” should be spelled “Plugin”.

    On the RATE & DONATE US tab, it should read: “RATE & DONATE TO US”

    Then the same with the heading above the Paypal button on that panel, it should read: “Donate to Us”

    These errors have always nagged at my writer’s side 🙂

    Inndesign

    (@inndesign)

    The problem appears to be the third-party dependency on Open Sans from Admin Custom Login plugin. It does not seem to be a problem in Google Chrome, but it does defect in Firefox Developer Edition. This is part of the big reason WordPress dropped Google Open Sans in WordPress 4.6, it was problematic. I accessed the Admin Custom Login Font Setting panel and selected Arial for every font choice. Once saved and cache cleared, the Times Roman was replaced as Arial and looked proper again. That seems to solve the problem for my sites. It might be ideal to modify Admin Custom Login to default to Arial at installation instead of Open Sans.

    It would be great if the above previously noted errors could be corrected too! Thanks.

    Anticosti

    (@anticosti)

    Same font issue for me.
    It only happens on iPhone.
    Browsers:
    Firefox / Opera / Edge / Safari / Chrome

    Anticosti

    (@anticosti)

    Thank you @inndesign,
    Your tip helped me to temporary solve the font issue.
    At least Arial looks way better than that famous overused Times.
    Let’s start a “Let’s Banish Times” movement 😉

    Netspark

    (@netspark)

    Hello @weblizar:

    Here are the requested Screenshots:
    https://imgur.com/42UdDgF
    and the result:
    https://imgur.com/0DU1TJM

    Although I set up “Cairo” from Google Fonts, it seems to fall back to the Browser’s standard display font which I have set to Arial at home. At work I am not allowed to alter the browser’s settings so it falls back to Times Roman instead. When opening the login page with IE or Chrome 79, guess what… there’s Times Roman back again.

    Interestingly other plugins I use which also access the Google Font API seem to have no problem at all and just work fine. I wonder what keeps the ACL Plugin from properly formatting the elements at all…

    In no case I was able to make the browsers render the login form with the selected font.

    Netspark

    (@netspark)

    Addendum: Did a rollback to Version 3.0.0 of the plugin and guess what… the font setting works as intended. It shows the Cairo Font setting in all browsers properly (IE, Chrome, FF).

    One thing though:

    The “Password” title appears not to use the font size settings like “Username” and “Activation code” title do.

    It is slightly smaller and while Username and Activation Code seem to use P tags, the Password area is nested in a div tag.

    Further code inspection shows that the div layer also discards the inherited font settings (18px as set in the plugin) and still applies 14px instead.

    I have attached the Code inspector screenshots for your convenience and to help you track down the issue.

    The form code:
    https://imgur.com/bHrGzyy

    and the CSS applied to the Username field
    https://imgur.com/W32NH7Y

    and here the CSS applied to the password field:
    https://imgur.com/3oM4VhA

    Plugin Author weblizar

    (@weblizar)

    Hi netspark,

    As you know some of you had issues in font-family settings. After investigation, we found out google API dropped some of them. We have removed other third parties font and now only using google fonts.
    So please change your font settings in admin-custom-login plugin font settings.
    The latest version of the admin-custom-login plugin

    Thanks

    • This reply was modified 12 months ago by weblizar.
    Netspark

    (@netspark)

    @weblizar:

    With the release of Version 3.1.3. I can confirm that the fonts are now properly displayed again as set in the Plugin settings. So the font selection issue is no longer to track and can be considered resolved. I still wonder what Google has changed that the GoogleFont API went berzerk and resisted to work at all.

    There’s only the password label issue remaining which I consider just a cosmetical but not important problem at all. Have sent you the code insector excerpts in my posts before to help you hunt down that little nasty bug that prevents the “Password” label to inherit the same font size setting like the “Username” and “Activation Code” label.

    Thanks for your great support!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Fonts No Longer Working’ is closed to new replies.