Support » Plugin: Really Simple SSL » Fonts have stopped displaying correctly

  • Resolved add.redford

    (@addredford)


    Hi there, first of all big thanks for the plugin.

    This is a bit of a strange one but immediately after implementing this plugin my theme fonts stopped displaying and reverted to some default font and I’m not sure what I can do to get them back. Do you have any suggestions?

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor Mark Wolters

    (@markwolters)

    Hi,

    the fonts are still loading over http://, this caused them to be blocked on https:// and the site will revert back to the default theme. This is usually fixed by re-saving the theme’s settings and clearing all caches your website uses.

    Thanks for the reply! You were right, the google fonts links in my css file still used http:// so I corrected it but can’t see an immediate change. And what’s even worse, it seems like the entire style.css from my child theme is no longer being loaded at all. I’ve had to paste my themes entire css file into the ‘additional css’ area as a temporary measure as that’s the only way I can get it to render the site (almost) properly. Do you have any idea what could be causing that?

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @addredford,

    In your stylesheet here:
    https://jackredford.com/wp-content/themes/online-marketer/style.css

    You can still see some http URL’s. These should be changed to https.

    I don’t see any reference to a stylesheet anywhere else, so possibly the child theme stylesheet is not loaded correctly. you can check with these instructions if your child theme css is loaded correctly:
    https://developer.wordpress.org/themes/advanced-topics/child-themes/

    Hope this helps!

    Besides fr

    Thank you! I had to add the full url along with https for every single link to an image file or font and that did the trick! Much appreciated 🙂

    In my case, RSSSL are messing the class “button, input, select, textarea” at dashboard… The fonts have been changed to Times New Roman. When I put !important tags to font-family: inherit; font-size: inherit; and font-weight: inherit; they back to normal style.

    Plugin Contributor Mark Wolters

    (@markwolters)

    Hi,

    the free version of Really Simple SSL doesn’t make any CSS changes to button, input select and textarea. The CSS is also only loaded on the own admin page so it shouldn’t affect the rest of your site. It’s possible another plugin or theme is loading a different/additional stylesheet while in https://, resulting in these changes.

    the problem happens when using RSSSL + Updraftplus…

    Plugin Contributor Mark Wolters

    (@markwolters)

    Hi,

    I have installed Really Simple SSL and Updraftplus on a new WordPress environment and don’t have this issue. Do you have any other plugins activate as well? There might be a different plugin causing this.

    Hi Mark, thanks for the reply…

    I have a lot of plugins installed, but the bug occours when I activate RSSSL.
    Te help button (inside plugin settings) on top right os the screen is displaying with Times New Roman…
    But this is a cosmetic bug only, that doens’t affect the my frontend, so I can live with him

    I’ve fixed removing “button{all:initial}” from main.min.css

    Plugin Contributor Mark Wolters

    (@markwolters)

    Thank you for letting us know, we will do some further testing and fix this.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.