Support » How-To and Troubleshooting » [Resolved] Fonts change for a second when page loading

[Resolved] Fonts change for a second when page loading

  • Hey,

    I’m new to WordPress so I’m not sure if this is a common issue/easy fix or not.

    When I load pages of my website, the font changes for a split second before the page is fully loaded. I’m using the Simplepress theme if that makes things easier.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Post a link? Which browser are you using?

    edmisa.com is the website.
    I tried on Chrome and Safari

    You have a premium theme. You should contact elegantthemes.com with your questions. That said, I didn’t notice the font change.

    Christine Rondeau


    Volunteer Forum Moderator

    I didn’t notice anything either. I think it looks good.

    I can’t seem to find a pattern of when it happens, but I’ve tried multiple computers and browsers and still see it. It’s only sometimes and on some pages. The “Leadership” page seems to be most prevalently showing the issue. When I click on “Leadership” from the navigation, the titles on the page show as a bold, bigger (and ugly) font for a split second.

    Thanks to all those trying to help!

    You are currently loading 9 separate stylesheets… You may want to go through them looking for @font-face rules. The blip you’re seeing could be caused by a font being downloaded. Maybe. Possibly the stylesheet requests a series of fonts like this: #menu-menu {font-family:Font1,Font2,times,serif;} or something similar, and Font2 is your bad-guy. I don’t know. Poke around in there and contact your theme vendor.

    I tried looking through the CSS and couldn’t find any issues. There was no “font-face” only a “font-family” that showed up 5 times. I tried playing around with them but it didn’t change anything.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Fonts change for a second when page loading’ is closed to new replies.
Skip to toolbar