Support » Plugin: Quick and Easy FAQs » FontAwesome not showing on FAQ page

  • Hi.
    I’ve created a page and the plugin works as I need, but in the page where I use the FAQ ShortCode all the Icons (Social and others) in the page are not showing up any more.
    Is it a bug?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Usman Ali Qureshi

    (@usmanaliqureshi)

    Hi,

    I have checked the page and also verified that font awesome is loading fine but for some strange reason, the icons are not loading on this page.

    Please tell me do you have any cache plugin installed?

    Thanks,

    Usman

    No chache Plugin is running at the moment.
    I’ve disabled the SiteGround Chache Plugin and flushed the chache, but nothing changes.
    Any idea?
    The only page that does not load the icons is that one with your FAQ plugin showing up.

    Plugin Support Usman Ali Qureshi

    (@usmanaliqureshi)

    Hi,

    The only reason I can think of the icons not showing is due to the CORS (Cross-Origin Resource Sharing) issue. However, the icons are showing just fine on the other pages.

    Anyways, please add the following piece of code at the end of .htaccess file in your website’s root directory:

    # ----------------------------------------------------------------------
    # CORS-enabled images/fonts and other stuff (@crossorigin)
    # ----------------------------------------------------------------------
    <IfModule mod_setenvif.c>
      <IfModule mod_headers.c>
        # mod_headers, y u no match by Content-Type?!
        <FilesMatch "\.(gif|png|jpe?g|svg|svgz|ico|webp)$">
          SetEnvIf Origin ":" IS_CORS
          Header set Access-Control-Allow-Origin "*" env=IS_CORS
        </FilesMatch>
      </IfModule>
    </IfModule>
    # ----------------------------------------------------------------------
    # Webfont access
    # ----------------------------------------------------------------------
    <IfModule mod_headers.c>
      <FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|font.css|css|js)$">
        Header set Access-Control-Allow-Origin "*"
      </FilesMatch>
    </IfModule>

    Let me know if the issue persists.

    Thanks,

    Usman

    I’ve added your code, but the issue persists.

    Any idea or other workaround?

    Regards.

    Plugin Support Usman Ali Qureshi

    (@usmanaliqureshi)

    Hi,

    Do you have any security plugins installed like WordFence?

    Thanks

    UomoMacchina

    (@uomomacchina)

    No.

    Plugin Author Sungraiz Faryad

    (@sungraiz)

    Hi,
    I’ve investigated your issue and found that you are using fab class along with the font-class which plugin isn’t supporting yet as you can see HERE
    We are continuously updating our plugin but for now, please replace the fab class name with fa in order to work the fonts properly.

    Thanks

    Sungraiz

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘FontAwesome not showing on FAQ page’ is closed to new replies.