Support » Plugin: Seriously Simple Podcasting » FontAwesome – Gizmo Font Conflict

  • Resolved lepalose

    (@lepalose)


    Hi there,

    I had a former issue that was resolved appear again. I use Salient theme that also uses an icon- class. The plugin is overriding the icon- class in this theme that uses ‘font awesome’ with the plugin’s use of ‘gizmo’, i.e.:

    [class^="icon-"]:before, [class*="icon-"]:before {
      font-family: "gizmo" !important;

    Previous thread where this was resolved:
    https://wordpress.org/support/topic/fontawesome-gizmo-font-conflict/

    Icons consequently appear as squares.

    Cheers,
    Lepalose

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the same issue with the Fluida Plus theme. Had to revert to previous plugin version to have the icons re-appear again. Must block this version update for now

    I’m having the exact same issue. My icons are all squares. Reverted back to an older version of the plugin that I had, but would appreciate a fix.

    Plugin Author Craig Hewitt

    (@podcastmotor)

    Thank you for the heads up on this conflict appearing on your sites. We’re looking into the best way to resolve this now and will be back in touch shortly once we have an update.

    I have the same issue with Virtue theme. I wait an update. Thank’s

    Hi there,
    I have the same issue with the Writer Ancora theme. Had to revert to previous plugin version to have the icons re-appear again. Waiting for an update. Thanks !

    Trying to find out how to use the (original theme ) CSS in the child theme so it will be independent of plugin updates. Should be a right way to avoid this (apart from the plugin itself not using double definitions)

    Plugin Author Craig Hewitt

    (@podcastmotor)

    If you’re still experiencing this issue could you send us a message at hello@castos.com with the version of SSP you’re currently running and a link to a page on your site where you’re seeing this happen so we can help troubleshoot things?

    Yes I am still experiencing the problem. Of course, since the plugin has not updated yest. This is the result with SSP 2.1.1. V 2.04 still worked well.
    You can see it on the homepage of https://www.ambientblog.net/blog as well as on every blogpost page.
    Please check asap if you want to see and let me know if you’ve checked it so that I can downgrade again because I don’t want to have these ugly squares up for too long.

    You already resolved this 2 years ago:

    https://wordpress.org/support/topic/fontawesome-gizmo-font-conflict/

    How can it be difficult to resolve now?

    Just scope your icons’ font family already.

    Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi all,

    The plugin update that was released today (v2.2.0) ought to resolve this. Please let us know if you’re still running into this issue.

    Fixed it, thanks!

    Plugin Author Jonathan Bossenger

    (@psykro)

    @ambientblog thanks for the update.

    aashish17vats

    (@aashish17vats)

    @podcastmotor

    I am using the Uncode theme and your plugin is breaking the icons on my entire website by placing a (U) symbol on the bottom left corner of every icon. I have tried updating the plugin to the latest version but still no fix.

    Can you please resolve this issue?

    Thanks

    Plugin Author Craig Hewitt

    (@podcastmotor)

    HI there, yes we’re working on an entirely new version of the player that will not use this font library. Hoping to have this out here shortly. This will resolve the issue you’re seeing.

    aashish17vats

    (@aashish17vats)

    @podcastmotor

    Thanks for the quick response. I really appreciate it. I hope to use the newer version soon. Please update once it’s out.

    Thanks

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.