Support » Plugin: OMGF | Host Google Fonts Locally » Font subsets not showing up

  • Resolved sunnyt13

    (@sunnyt13)


    Hey there!

    Everything was working great for me, but I recently clicked “Empty Cache Directory”, and now I actually can’t get any fonts to show up in the list.

    I’ve tried searching for something like Poppins or using auto detect, and even though I get a “Subset search complete. Select subsets to generate a list of available font styles.” notification, I still just see “No subsets found. Use Search or Auto Detect start.” under the available subsets.

    I’ve tried removing all settings, deactivating, uninstalling, and reinstalling, but still nothing. I know it was working the moment before I cleared the cache directory as well.

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • @sunnyt13 , I’ve been there too. Did you reload your latest post or page as instructed at the top of the settings page. It’s easy to miss if you are lower down the page clicking auto-refresh.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Hi guys,

    I just released v4.0.0 of OMGF, which runs entirely automatically. Making Auto Detect and tailoring the font list obsolete.

    So, update, and all your worries should be gone. 🙂

    Installing custom fonts will be released as an addon for those who use it (it’s not a very popular feature) soon.

    Enjoy!

    @daanvandenbergh ah, cool!

    Just as a heads up, I updated the plugin on the client’s site, but the fonts are getting blocked by GoDaddy’s firewall now.

    URL: …/wp-json/omgf/v1/download/css?family=Pinyon+Script%3A400&handle=fl-builder-google-fonts-a562250176e7d96764f3a6b3f56a3627&ver=5.5.1
    Block ID: XSS025
    Block reason: An attempted XSS (Cross site scripting) was detected and blocked.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Wow… How is calling an internal API an XSS attempt?

    I’ll check if there’s a way to work around this. Thanks for notifying me!

    Hah, I have no idea! I haven’t tried it on any of my personal sites yet, but yeah it doesn’t look like Sucuri is a huge fan.

    Thanks again!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.