Support » Plugin: OMGF | Host Google Fonts Locally » Font only showing for logged user

  • Resolved phoenix0308

    (@phoenix0308)


    Hey,

    the title section font is not appearing for not logged users. I really dont know why.
    Its the font Kaushan Script.

    Thanks for your help πŸ™‚

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Yeah, this new setting is not right. Logged-in users should see local fonts on the front end, and definitely in the customizer.

    The default for this setting should be “on” and/or it should be changed to “Disable local fonts for logged-in users”.

    Honestly, Daan, I don’t see the use case.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    I know. I’ll fix that in an upcoming release.

    The use case: if you’re switching themes and running customizer, but you have OMGF setup to run with your previous theme (with Remove Google Fonts? enabled) the fonts of the theme aren’t shown, because they are removed.

    But yes, it should definitely be on by default.

    Guys i dont understand… the fonts are loading for logged users, but not for not logged users. I want that everyone der them, what I have to change.. i dont see any options for this in the settings.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Isn’t this a caching issue, or something? Disable all caches and css minifiers/combiners and check again.

    I am using Autoptimizer and WP Rocket. I have both deactived now and the issue is still there.
    With Autoptimizer on another page the font was not loaded correctly, when I deactived it was fine. So do you have any script that I can except from AO.

    On this page, still same issue. When logged I see the font, otherwise no:
    https://world-taste.de/rezepte

    Edit: *ONLY when logged as admin

    • This reply was modified 8 months, 3 weeks ago by phoenix0308.

    What makes you think the fonts aren’t loading? I can see them on the page and in effect.

    Also, with WP Rocket, you really don’t need Autoptimize, because you can configure WP Rocket to combine and minify files.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Also, with WP Rocket, you really don’t need Autoptimize, because you can configure WP Rocket to combine and minify files.

    That’s a great suggestion.

    Also, with WP Rocket, you really don’t need Autoptimize, because you can configure WP Rocket to combine and minify files.

    well, some people do consciously prefer to use both and let AO do the combining & some other stuff because it _can_ lead to better results πŸ˜‰

    I’m a fan and use AO on several sites, but I’m also a minimalist.

    Hi,
    i can confirm what @phoenix0308 said. fonts are loaded for all (guest and subscriber) but not for administrator.
    checking “Optimize fonts for logged in editors/administrators will fix it and then regenerate stylesheet + purge cache (on my case i use Litespeed).
    BIG thanks for @daanvandenbergh for this amazing and must have plugin.KUDOS!

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Hi guys,

    I just released an update, in which the ‘Optimize fonts for logged in editors/administrators?’ setting is enabled by default.

    Apologies for the inconvenience.

    Hi

    So what’s the solution?
    I have the same problem and I can’t fix it

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Check if the option is disabled under OMGF’s Advanced Options. If not, enable it!

    which option @daanvandenbergh ?

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Optimize fonts for logged in editors/administrators? Under Advanced Settings.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.