Support » Plugin: Easy Google Fonts » Font not changing

  • Hello,

    I have installed this plugin. I am trying to change all fonts to Ubuntu, but Georgia is still showing as the font. How do I fix this?

    Thank you,
    Katie

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello! I do not know if yours is the same problem but I found that when I created my CSS selectors in the Settings menu I typed it wrong.

    You have to name it exactly as you would when creating a stylesheet.

    In other words I wanted a class called ‘site-title’ but the correct way to type it is .site-title , notice you NEED the period in front to designate it as a class. The same would go for the pound symbol (hash-tag, #) to identify an ID.

    I’m sure you have long since figured this out, but I hope this post helps other people.

    • This reply was modified 1 month, 1 week ago by  coreigh.
    Dlo015

    (@bubbles015)

    @coreigh I am having the same issue as @arhsnsw and all of my classes have the period. Still not working. Mine, in fact, won’t even save. I put in my title, then enter all of my selectors (I have a lot since I am changing the entire site of my theme’s default font), and check the box that says “force styles override” and hit save. It won’t save. Just a continuous little spinning circle as if it’s trying to save, but nothing happens. It’s been spinning now for hours.
    Doesn’t save, therefore can’t change my fonts in the customize screen.
    Any ideas?

    @arhsnsw posted this issue months ago and there has been no responses from the developer. It seems quite a lot of issues and questions in the forum are ignored. No help. Some questions have been sitting unanswered for a year. ???

    Thanks for any help you can give!

    @Dlo015, Do you at least have the Typography section in your Theme Customizer? If not then maybe the plugin did not install properly?

    Two thoughts on the “It won’t save” issue: 1) you may just need to log out of wp-admin and log back in, but #2 Do you have a valid Google Font API key AND #2b do you have the API key authorized for Fonts and for the domain of the site you are working on?

    I beat my head against the wall all afternoon one day because even though I had an API key I had not authorized it for Fonts …

    Also you mentioned you have many selectors; It may be easier to trouble shoot a single selector and get ONE working, so you know it works, and then add the rest.

    To anyone else finding this plugin less than intuitive I found this link someehat helpful as a “Getting-Started” type document:
    https://www.inmotionhosting.com/support/edu/business/recommended-wordpress-plugins/easy-google-fonts-plugin

    • This reply was modified 3 weeks, 1 day ago by  coreigh. Reason: added a link
    Dlo015

    (@bubbles015)

    @coreigh Thanks for the quick response! I really appreciate it!

    I do have the API. My other Titles with different selectors show up on my Topography and those were able to be saved and I am able to change my fonts and such. It’s just this batch that won’t save.

    I had the same thought as you earlier and I eventually did exactly what you said and cut out a number of selectors and it finally worked. I guess some of the selectors it just didn’t like? Sort of frustrating because now those selectors are my theme’s default font as I was able to change only some of the selectors. Boo! It’s just aesthetic, but I’m a perfectionist and it has driven me mad!

    Thanks again

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.