Support » Plugin: Kirki » Font Issues

  • Resolved RobertGrimley

    (@robertgrimley)



    Hi

    Since the May 15 update to Kirki the fonts on my site have changed. This same thing happened a few weeks ago until you put out a fix…

    In my theme (using the customiser I can’t even select any Google Fonts any more). The site just hangs…

    If you are going to make such major changes to code can’t you tell people of the potential damage it may cause in advance… ITIL Service validation and testing before release out to production…

    Can you check it out please?

    Thanks

    Robert

    • This topic was modified 6 months, 1 week ago by  RobertGrimley.
    • This topic was modified 6 months, 1 week ago by  RobertGrimley.
    • This topic was modified 6 months, 1 week ago by  RobertGrimley.
    • This topic was modified 6 months, 1 week ago by  RobertGrimley.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Update the wp-content is writeable (755) but I do not see any folder called wp-content/webfonts following the update…

    Plugin Author Aristeides Stathopoulos

    (@aristath)

    Can you check v3.0.31 released just a few minutes ago?
    If the issue persists after updating, can you please check your error log and let me know if there’s anything wrong there?

    Hello

    Installed v3.0.31

    Still not working however the Google fonts did reappear in the customer/typography options but have since gone! Weird…

    Thanks

    Robert

    • This reply was modified 6 months, 1 week ago by  RobertGrimley.
    Plugin Author Aristeides Stathopoulos

    (@aristath)

    v3.0.31 simply adds a fallback, so in case the fonts were not writeable on your server and the files don’t exist, it falls-back to the google-CDN version of those files.
    As for when in the customizer, nothing changed. Things are exactly the same there and nothing has changed since v3.0.27

    Okay can you give me the link to 3.0.27 so I can roll back whilst you look at it?

    Many thanks

    Robert

    Plugin Author Aristeides Stathopoulos

    (@aristath)

    Can you please try deleting the plugin and re-installing? I just saw a change had not been pushed so I pushed it just now on the wordpress.org repository.

    If that doesn’t work either (it should, but just in case), then on the bottom of https://wordpress.org/plugins/kirki/advanced/ there’s a dropdown where you can download previous versions.

    Okay I installed 27 and its awesome again… My site looks correct (fontwise) and is super fast again..

    I’ll try 31 again and report back…

    Okay thanks. So now using 31 the fonts look okay but when selecting them in the customiser>typography its sluggish now and they literally appear to vanish from the option menu…

    Maybe I should let it settle down for a while…

    I have the roll back option if you do some more investigation…

    Robert

    I had to go back to 27 as 31 was causing my site to run sluggish and typography options in the customiser became random (for lack of a better word) … Everything is perfect again under 27 though…

    Thanks

    Robert

    Plugin Author Aristeides Stathopoulos

    (@aristath)

    Version 3.0.32 was released.
    It basically revers the previous changes and now font-loading is exactly the same as it was.
    The only difference is that now there’s an additional checkbox in typography controls that lets you host google-fonts on your own server so that a site can be GDPR-compliant without any issues.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Font Issues’ is closed to new replies.