Support » Plugin: Gutenberg » Font size in Editor switched to unreadable, front end unchanged though.

  • Dear team:

    I ruled out plugin conflict. But from one moment to the other my editor shows everything pretty small. Unreadable unfortunately. It´s not a Zoom Issue, I pushed a lot of buttons and made tests, with theme design activated in editor and without …all to no help at all. Is this a known issue? How would I be able to write in the editor again? I know that technically I could choose for every single block in the editor, yes, but that´s really time-consuming and seems unnecessary. Is there a way to force GB to accept the same styling as in frontend? Front end is NOT affected, strangely! Also, buttons, Gutenberg intern menus, nothing changed! Just the typing text, h elements and p elements! Thx for your input! Cheers!!!!!

    • This topic was modified 1 month, 2 weeks ago by Honkytonky.
    • This topic was modified 1 month, 2 weeks ago by Honkytonky.
Viewing 4 replies - 1 through 4 (of 4 total)
  • This sounds like a theme issue to me i.e your theme does not have styles for the editor screen. What theme are you using?

    Dear Jamie, the theme´s name is Typology. But the strange thing is that it worked. And suddenly it went to “Be sure to put your loupe on your desk before writing.” :-). I am still on it. No luck so far! If I would want to overwrite a CSS class, you know which one that would have to be. I would fiddle around with injecting a css rule! Thx for getting back to me!

    Oh yes, now I see, it seems that the backend loads the post with

    .editor-styles-wrapper {
    font-size: 62.5%;
    }.

    By deactivating the rule in the console however (ticking it off), fonts switch back to normal just like before and I can read and write as usual. Unfortunately I can´t manage to overwrite the class with css/ important rule. Would you know of a way how to achieve this?

    Cheers!

    • This reply was modified 1 month, 1 week ago by Honkytonky.
    Plugin Author Isabel Brison

    (@isabel_brison)

    Hi! This does seem like a theme styling issue, because that CSS doesn’t come from Gutenberg, and editor-styles-wrapper is the class the editor attaches to all theme-defined editor styles.

    I suspect this is a side effect of the “use theme styles” toggle being broken, so that theme styles are now always on even if they had previously been disabled.

    We are working to fix this issue in the plugin. Meanwhile, it might be worth reporting as a styling issue with the theme, as enabling theme styles in the editor should definitely not result in an unreadable font!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.