Support » Theme: Quark » Font Awesome not displaying

  • Resolved french_toast



    Font awesome is not loading for me

    I’ve hidden it for the time being.

    Web Fonts are where they should be: themes/quark/fonts & this is in the htaccess:

    <FilesMatch "\.(ttf|ttc|otf|eot|woff|font.css)$">
      <IfModule mod_headers.c>
        Header set Access-Control-Allow-Origin "*"

    I’m running a few different websites from a single server which could be causing the issue. (Fonts were displaying fine when I was working locally on the theme)
    I’m new with using WordPress so apologies for my ignorance. Beautiful theme btw.

    Thank you for your time

Viewing 9 replies - 1 through 9 (of 9 total)
  • Theme Author Anthony Hortin


    Looking at the source of your web page, it looks like the font-awesome.min.css stylesheet is actually getting loaded ok. Could you please supply a URL of your site where you’re trying to actually display the icon fonts, as I couldn’t find a page that’s using them.

    Also, try changing the above lines to the following

    <FilesMatch ".(ttf|otf|eot|woff)$">
      <IfModule mod_headers.c>
        Header set Access-Control-Allow-Origin "*"

    This will only resolve issues with fonts that aren’t displaying due to using a CDN, which causes problems for FF and IE as they have a ‘cross-domain’ issue.

    Hi Anthony

    The Parent Menu item is now showing a font-awesome character, which is just rendering as a box


    Theme Author Anthony Hortin


    Can you confirm if you/your host is actually using a CDN?
    Did you change the lines in the .htaccess files as I mentioned?
    Also make sure you clear your CDN’s cache.

    Did some research & my host isn’t using a CDN.
    I tried replacing the .htaccess files as mentioned with no change.

    Any more ideas?

    Theme Author Anthony Hortin


    Can you please make sure that the fontawesome-webfont.woff file is in the themes/quark/fonts folder as it doesn’t appear to be loading. The browser is returning a 404 error on that file. I’d suggest copying up the whole fonts folder to your server again.

    Yes, all fonts are in the correct folder.

    Did some more research & it seems it’s a hosting issue with GoDaddy.

    PLEASE HELP!…@fontface not working with GoDaddy

    I’ve tried moving the font files into the css folder & changing the corresponding file paths to no avail. I’ve also double checked folder permissions are OK.

    At wits end with this.
    Moral of the story, don’t use GoDaddy.

    Theme Author Anthony Hortin


    Something else for you to try…

    Try changing the font path for all the font files in css/font-awesome-min.css to a fully qualified path.

    ie. change

    Do this for each of the font files that it references (.eot/.woff/.ttf/.svg)

    Tried changing the file path as requested but it didn’t work.

    I did try clipping the “?v=3.2.1” from the file paths & the icons are up & running (although not in Firefox)

    How will clipping the version number effect the fonts?

    Thanks for your time & persistence.

    Theme Author Anthony Hortin


    To find out more about using font-face, I’d suggest reading through this article by Paul Irish –

    Basically, the parameters on the URL string are for cross browser compatability. I wouldn’t recommend removing them.

    If you’ve tried all the recommended solutions in those articles that talk about GoDaddy issues, as well as all the suggestions that I’ve mentioned above, and you’re still having issues, then the only other thing I can suggest is that you move webhosts.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Font Awesome not displaying’ is closed to new replies.