Support » Plugin: WP Google Maps » Font Awesome GDPR Compliance Problem

  • Resolved BMove

    (@bmove)



    Hello,

    the latest update puts font awsome script on every page of my Website. Because of the new GDPR Compliance i dont want to use it. Can i deactivate this somehow?

    Greetings

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author perryrylance

    (@perryrylance)

    Hi there

    Thank you for getting in touch and thank you for reporting this.

    FontAwesome should only be enqueued on pages with a map on,

    Can you please direct us to such a page so we can investigate this issue?

    Kind regards

    I have downgradet to 1.6. But it was the same on all Pages. It includes the Script on every Page. I have tried it on several WordPress Websites. Itยดs only happening with 7.01.

    Andreas

    (@sauerland)

    I have the same problem. The Font Awesome conflict is not only on pages where there is a map (https://wohngemeinschaften.smmp.de/). It affects the entire website (https://static6.smmp.de/).

    • This reply was modified 7 months ago by  Andreas.
    Plugin Author perryrylance

    (@perryrylance)

    Hi there

    My apologies for the inconvenience caused by this issue.

    We’ve just released a patch that gives you the option to choose between FontAwesome 4, FontAwesome 5 and “None”.

    We are working to address this library being loaded on every page, please bear with us, this will be patched shortly.

    Kind regards
    – Perry

    BMove

    (@bmove)

    Thank you very much ๐Ÿ™‚ No apology needet. Thank you for you great service :).

    • This reply was modified 7 months ago by  BMove.
    marc.shade

    (@marcshade)

    How can I get the patch to set the version of FontAwesome back? We have several websites that are using your plugin and it’s breaking any other instances of FontAwesome icons we’re using. So, we have live client websites with broken icons.

    Thanks,
    Marc

    Plugin Author DylanAuty

    (@dylanauty)

    Hi Marc (@marcshade),

    Thank you so much for your time, and out apologies for the delay in response.

    We have recently released an update which allows you to alter the version of FontAwesome loaded by our plugin, or alternatively disable it entirely.

    Please ensure you are using the latest version available, 7.0.02, and navigate to Maps -> Settings -> Maps (tab) -> And alter the ‘Use FontAwesome’ option from within this area.

    I hope this helps? ๐Ÿ™‚

    Hi,

    I’m using 7.10.10 and have FontAwesome set to ‘None’ but it still appears as:

    <link rel='stylesheet' id='fontawesome-css' href='https://www.mywebsite.co.uk/wp-content/plugins/wp-google-maps/css/font-awesome.min.css?ver=4.9.6' type='text/css' media='all' />

    If I change it to version 5 it changes to:

    <link rel='stylesheet' id='fontawesome-css' href='https://use.fontawesome.com/releases/v5.0.9/css/all.css?ver=4.9.6' type='text/css' media='all' />

    Any ideas?

    Paul

    Plugin Author DylanAuty

    (@dylanauty)

    Hi Paul,

    Thank you so much for your time on this one.

    Could I ask you to please open a support ticket with us here: https://www.wpgmaps.com/contact-us/ – As this will allow one of the developers to take a closer look into this for you.

    I look forward to hearing from you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.