Support » Plugin: Strong Testimonials » Font Awesome dont disable

  • Resolved nicogaldo

    (@nicogaldo)


    Hi, I want to disable the “font awesome” loading option as the plugin gives the option, but it does not work.

    I disable the option, but it keeps loading. I have already loaded font awesome by the theme and its plugin creates a conflict.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor Chris Dillon

    (@cdillon27)

    Please post a link to the site. If not here, then send it to chris at strongplugins.com.

    Are you using any caching?

    Have you looked at the page source code? If you’re not familiar with that, hit Ctrl+U or right-click on the page and select “View page source”. Then Ctrl+F and search for “font-awesome”. If you find it, copy and paste that entire line of code here.

    Thread Starter nicogaldo

    (@nicogaldo)

    It seems that what it does is to change of place the line of code? Look at the image: https://k61.kn3.net/47C67D6A0.png

    Plugin Contributor Chris Dillon

    (@cdillon27)

    Thanks for the image. I see you’re working on localhost. Are you using any plugins for caching, optimization, or CDN? If so, which ones?

    Thread Starter nicogaldo

    (@nicogaldo)

    No, the site is in development, not cache, not cdn.

    For now edit your plugin file so I do not load font awesome

    • This reply was modified 5 years, 5 months ago by nicogaldo.
    Plugin Contributor Chris Dillon

    (@cdillon27)

    OK. Does the problem still happen if you switch to the Twenty Seventeen theme?

    Thread Starter nicogaldo

    (@nicogaldo)

    yes, still happen

    Plugin Contributor Chris Dillon

    (@cdillon27)

    OK. Try this. Open a new Chrome window in Incognito mode. Hit F12 for Dev Tools then F1 for Settings. Disable cache while DevTools is open.

    devtools-cache

    Thread Starter nicogaldo

    (@nicogaldo)

    Still happen, are you testing and working correctly?

    Plugin Contributor Chris Dillon

    (@cdillon27)

    See for yourself. Look at the source code here:
    http://dev.gapcraft.com/test/

    Thread Starter nicogaldo

    (@nicogaldo)

    I’m going to do some tests again, with no plugins and with the default theme. Then I’ll let you know.

    Thanks for the quick answers!

    Plugin Contributor Chris Dillon

    (@cdillon27)

    Any news on this?

    Thread Starter nicogaldo

    (@nicogaldo)

    I have not had time to do the tests, soon I will do them! for now the problem persists in the last version.

    Thread Starter nicogaldo

    (@nicogaldo)

    I have done a clean installation, and I have only installed its plugin. When I turn off the awesome font loader, it keeps loading anyway. The theme you use is the wordpress default.

    Plugin Contributor Chris Dillon

    (@cdillon27)

    My apologies; you are correct. I found one instance where it is loaded despite the option being disabled.

    I will fix this in the next minor update. Until then, there are two ways to fix it.

    Either add this to your theme’s functions.php:

    /**
     * Deregister Font Awesome in Strong Testimonials
     */
    function my_deregister_fontawesome() {
    	wp_deregister_style( 'wpmtst-font-awesome' );
    }
    add_action( 'wp_enqueue_scripts', 'my_deregister_fontawesome', 15 );

    or edit the template file

    wp-content/plugins/strong-testimonials/templates/modern/content.php

    and remove this line near the top:

    * Styles: wpmtst-font-awesome

    Thread Starter nicogaldo

    (@nicogaldo)

    Thanks Chris!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Font Awesome dont disable’ is closed to new replies.