Support » Networking WordPress » Font Awesome does not show on www urls

  • Hi,

    I have a multi-site installation. Font Awesome is working on all sites without any problem, providing the website url does not have www.

    However when I manually put in the www before the url, the Font Awesome icons become small blank squares.

    How do I activate Font Awesome on the www side of the website?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi there,

    Can you share a link of the affected site? This would help in actually diagnosing the issue.
    Thanks

    The site is currently under construction, and locked.

    The website deafsports.nz has Font Awesome working, but http://www.deafsports.nz does not.

    The password to view the site is: D34FsportsNZ

    This is not the password for the admin section.

    Hi dharborne,

    The error you’re facing is due to a thing called CORS. This is the error

    Font from origin 'http://deafsports.nz' has been blocked from loading by Cross-Origin Resource Sharing policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://www.deafsports.nz' is therefore not allowed access.

    You’ll have to decide if you want to keep the www or not. If you decide to keep the www:

    1. Change the site url and WordPress url in the settings to include www
    2. Redirect deafsports.nz to http://www.deafsports.nz in your Apache Vhost configuration

    If you decide to keep the site as is, then you’ll need to redirect http://www.deafsports.nz to deafsports.nz in your Apache vhost config.

    You’ll need to contact your web host to know how to change the Apache config in your particular environment.

    Cheers 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Font Awesome does not show on www urls’ is closed to new replies.