WordPress.org

Support

Support » How-To and Troubleshooting » font and character/symbol issues

font and character/symbol issues

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’ve seen this before, when I’ve moved a site from one location to another, or rebuilt a database from a backup file. It has something to do with a change in character sets.

    If you look at it, it seems like they are in places on your post that might be fancy quotes and apostrophes.

    I was able to clean up most of what I ran into using SQL replace and update commands in phpMyAdmin. If you are interested I can post some code to use as a starting place.

    Any help would be appreciated, thanks. Probably a result of recent server problem.

    Hi

    If your database had to be restored from a backup dump script, that is where I have seen this issue before.

    1) BACK UP YOUR DATABASE BEFORE YOU DO THIS. Have the backup zip file or SQL file in hand!

    2) This code assumes your tables use the default prefix of ‘wp_’

    The way I fixed these was with copy and paste – copy one string of garbled characters and paste it into an SQL statement. More than likely if I paste garbled chars from your site this forum software will strip it out, so I am using x3!29* as a stand-in – where you see that, paste in one occurrence of garbled characters from your site. The code replaces all occurrences of that one garbled string with an empty string, i.e. removes the garbled and puts nothing in its place.

    You will run the code in phpMyAdmin, then refresh the website page in the browser. If there are further strings of garbled characters, paste the next combination into the SQL statement, and run the query again, until all the garbled characters are gone. The advantage of this method is running the statement once cleans up every occurrence of that string in every post on the site.

    UPDATE wp_posts SET post_content = replace(post_content, 'x3!29*', '');

    If you need instructions on how getting into and use phpMyAdmin, see this tutorial. Its about lost passwords. You don’t care about the password part. The part to use is the part about getting into phpMyAdmin, and how to enter and run a SQL statement.

    http://codex.wordpress.org/Resetting_Your_Password#Through_phpMyAdmin

    Do remember to make that backup first! If you pay attention and work slowly everything will be fine.

    I fixed the problems in the post linked above so I thought I should offer a new example link here (notice the frequent Â):

    http://collectedmiscellany.com/2008/11/ten-questions-with-michael-rosenberg/

    I haven’t had time to try the solution above. Any other suggestions welcome.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘font and character/symbol issues’ is closed to new replies.