Support » Plugin: WP Socializer » Follow Bar Only Shows When Logged In

  • Resolved jstec


    I have the Follow Bar set to display as vertical, on the right middle of all pages. I am also using a follow bar widget in a footer area to display social follow buttons horizontally.

    I have been debugging an issue with the vertical follow bar on the right edge disappearing with the 3.3.1 update today. I could not make it work, so I rolled back to 3.3. I thought I was losing my mind when it reappeared and then sometime later disappeared on its own.

    What I discovered is that with 3.3, whether the vertical follow bar shows is dependent on whether or not I am logged in (shows) or not (doesn’t). After re-applying the upgrade to 3.3.1, the vertical follow bar is not showing up at all, regardless of whether or not I am logged in.

    The site is and, unfortunately, it is a client site, so I can not give you admin access.


Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author vaakash


    Hi @jstec
    Thanks for reporting this.

    But AFAIK there is no issue with the plugin.

    I guess you didn’t perform a “hard refresh” (ctrl+f5) after installing the plugin ( or page is cached )

    If possible please install 3.3.1, enable the follow bar and share me the website URL alone, I’ll check and let you know immediately. There is no need for a login.


    Hi @vaakash – thanks for the reply.

    Well, it seems my problem is definitely a caching issue, as the followbar that should be on the right side is not showing up at all now – regardless of whether I’m logged in or not. Version 3.3.1 is installed.

    The website URL is in my original post.

    Also, I have uploaded screenshots of my settings to my Drop Box:

    Question: Is there a conflict with using a followbar widget *and* the general settings to make followbar appear on every page? I’d like the vertical stacked followbar in the right side of my page, and a horizontal arrangement in my Footer 4 widget area.


    Plugin Author vaakash


    Ok, I found out that it is not seen because, your website is having lot of Javascript errors.

    You can paste the below code under WP Socializer -> settings -> additional css rules
    Once pasted, regardless of JS errors followbar will be seen.

    .wpsr-followbar {
        display: block !important;

    ( image of console, there is an infinite loop of javascript errors caused by someother plugin/theme. Please fix if possible )


    • This reply was modified 1 year, 10 months ago by  vaakash.

    Yes! That solved it, tyvm.

    I did notice the loop throwing JS errors, and I have an email in to support at the offending plug-in provider.

    Your cup of coffee is on its way!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Follow Bar Only Shows When Logged In’ is closed to new replies.