Support » Plugin: Adaptive Images for WordPress » Folder not Created

  • Hi there,
    first of all, thank you for your plugin.
    On my side it is nor working and I don’t know why.

    The Debugg say the folder is not created. Also the calculated size is 0.

    Here is the Debug may be you can help me?

    PHP GD library is installed.

    ✖ Image cache directory has not been created.

    But this is probably because the cache has not been accessed yet.
    After accessing your website from a mobile device the directory should be automatically created.

    . => drwxr-xr-x

    ✔ Installation .htaccess file is setup OK.

    /www/htdocs/w0189867/opti.websites4startups.de/.htaccess => -rw-r–r–

    ❖ Adaptive images settings dump:

    array(14) {
    [“resolutions”]=>
    array(13) {
    [0]=>
    int(1920)
    [1]=>
    int(1800)
    [2]=>
    int(1700)
    [3]=>
    int(1600)
    [4]=>
    int(1500)
    [5]=>
    int(1400)
    [6]=>
    int(1300)
    [7]=>
    int(1024)
    [8]=>
    int(900)
    [9]=>
    int(800)
    [10]=>
    int(640)
    [11]=>
    int(480)
    [12]=>
    int(320)
    }
    [“landscape”]=>
    bool(true)
    [“cache-directory”]=>
    string(0) “”
    [“watched-directories”]=>
    array(0) {
    }
    [“jpeg-quality”]=>
    int(90)
    [“sharpen-images”]=>
    bool(true)
    [“watch-cache”]=>
    bool(true)
    [“browser-cache”]=>
    float(0)
    [“hidpi”]=>
    bool(false)
    [“cdn-support”]=>
    bool(false)
    [“version”]=>
    string(6) “0.6.64”
    [“sanitized”]=>
    bool(true)
    [“wp-content-dir”]=>
    string(57) “/www/htdocs/w0189867/opti.websites4startups.de/wp-content”
    [“wp-content-url”]=>
    string(44) “https://opti.websites4startups.de/wp-content”
    }

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takis Bouyouris

    (@nevma)

    Hello, my friend,

    Thank you for reaching out to us!

    It seems from your settings that the Watched directories property is empty. Is this true? Our plugin needs to have this property properly set in order to know in which directories it needs to watch out for images to resize. Usually the defaults are good enough and they entail /wp-content/uplοads and /wp-content/themes.

    Also, although your HTTP headers report that you are using Apache and your settings say that your htaccess file is correctly edited, it seems that the requests for images do not even reach the WordPress installation and our plugin code. Are you perhaps using a CDN or some other caching solution?

    Cheers,
    Takis

    Every time I write something in the “Watched directories” box and save. it is not saving.
    I Disable all WebP Express, and Caching plugins. but still not working.
    Could you helping me if I give you the login data to have a look?
    I think I am missing here something. But don’t see it.

    What does that mean?
    Directories to watch for images to resize for mobile devices. Has to be relative paths inside your WordPress installation.

    Can I do it like: https://opti.websites4startups.de/wp-content/

    Plugin Author Takis Bouyouris

    (@nevma)

    Hello, my friend,

    This is indeed very weird (not saving the Watched directories setting)! This setting defines the directories where our plugin looks for images to resize. So, it will not resize images in other directories. This way you can control part of its behaviour, in case you need some images to remain non-resized at all cases. And, yes, it needs to be a relative path within one’s WordPress installation, like “/wp-content/themes/”, etc.

    Usually, as I mentioned in my previous email the defaults should be good enough for most cases. Did you by any chance delete the default values? If not, it seems that your host is perhaps filtering the data sent in HTTP requests and strips away data that it identifies as directory paths. But this is just a guess.

    It would require to have access to the WordPress installation files via (S)FTP in order to debug this I am afraid. If you wish, I would be happy to take a look into it. You can send me the credentials at info [at] nevma [dot] gr.

    Cheers,
    Takis

    Hi Takis,
    I send you an email.

    Cheers,
    Christian

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Folder not Created’ is closed to new replies.