Support » Plugin: 404 Solution » Folder Ignore Strings following Update

  • Resolved Chad

    (@lonesync)


    Hello,

    Following the latest update today, folders within the ignore strings are now processed. In particular (/.well-known/acme-challenge/….) – settings all remain the same, update was completed earlier and now this string shows up in captured.

    Any thoughts on what could be causing this scenario?

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Aaron

    (@aaron13100)

    Hey Chad,

    Well there’s no reason the update should have caused this after looking at the code again.

    Maybe there was an issue with the update. You could try uninstalling and reinstalling the plugin.

    I tested the “Files and Folders Ignore Strings” part and it’s working for me with “*.jpg” locally and on a remote site. With the example you gave though, “/.well-known/acme-challenge/*” I had to remove the leading / and add a star at the end to get it to work.

    So “.well-known/acme-challenge/*” instead of “/.well-known/acme-challenge/…”

    If you turn on debug logging (check the box at Settings -> 404 Solution -> Options -> Advanced Settings -> Debug Logging), then test the string you want to be ignored again, there should be messages in the log file about what happened. It will start with

    Processing 404 for URL: /.well-known/acme-challenge

    and include either
    Logging redirect. Referer: | Current user: ??? | From: /.well-known/acme-challenge/

    (when the ignore string was not matched) or

    Ignoring file/folder (do not redirect) for URL: ??????, pattern used: ^\.well\-known\/acme\-challenge\/.*$
    and
    Logging redirect. Referer: | Current user: ??? | From: ????? to: 404, Reason: ignore_donotprocess [...]

    (when the ignore string was matched).

    So… please try it with *.jpg and see if it works with http://www.yourURL.com/any.jpg. If it does then it must just be the way the pattern is written, I guess. Otherwise try uninstalling and reinstalling. Otherwise turn on debug logging and send me the results here.

    thanks

    Hi Aaron,

    Much appreciate your quick update here – all other redirects were working, so upon reading your troubleshooting removed ignore strings, saved and then re-added the strings and ‘voila’…all is good again 🙂

    Strings were added with the removal of the forward slash and following asterisk prior which worked beautifully, same results now. There are no other caching plug-ins or such, so maybe just an update bug and by resetting corrected.

    Oh..wanted to mention thanks for the last update also – really nice improvement for selecting pages, posts, tags…within redirect, clean and organized for quick work.

    Thank you!

    Plugin Author Aaron

    (@aaron13100)

    Great! Good thinking just removing and then re-adding the strings. I didn’t think of that.

    Glad to help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Folder Ignore Strings following Update’ is closed to new replies.