Support » Plugin: Yoast SEO » Focus keyword missing

Viewing 6 replies - 1 through 6 (of 6 total)
  • Nile Flores

    (@blondishnet)

    Yoast Support

    Hi mapri22!

    If the keyword is missing in the description, as the message is telling you, then that means it may be missing from your meta description, and not your 1st paragraph. You can edit your meta description in your Yoast SEO metabox’s snippet editor.

    Did you mean that the focus keyword was missing from your 1st paragraph instead?

    Thanks Nile, but the focus keyword is in my meta description and 1st paragraph as well, check it out here please http://i.imgur.com/u3F0fKi.jpg
    Thanks

    @mapri22

    Your focus keyword has a comma in it that is not in the description. Make sure an exact match is used and it should then be found.

    Hi Kim, there is no change when I delete the comma, still get this message http://i.imgur.com/MHVhD5u.png (means, there is no focus keyword in my first sentence in my article), but the focus keyword is there, please check out this http://i.imgur.com/bnLtzMe.png I think there is a problem with your plugin. Could you check that please. Thanks.

    Nile Flores

    (@blondishnet)

    Yoast Support

    Hi mapri22!

    Can you please take a screenshot of the content box of that page so we can check it. If you have a subheading or any code before the 1st sentence/ 1st paragraph, then the plugin is working as expected. It’s just that according to WordPress, the other content like a shortcode, or a heading/title/ subheading (h2, h3), or an image, would be first.

    In this case, because you see it there, it can be ignored.

    If this is not the case, please share a screenshot of your content editor for that page/post so we can see how you’ve set up the post. Thanks!

    (If that 2nd screenshot was the visual editor of your content box, then it means you do have a subheading 1st, and can ignore the suggestion in the content analysis tool.)

    Hi Nile, here is the sreenshot http://i.imgur.com/B6r7caQ.jpg

    As you can see there is nothing like header, shortcode etc. before first sentence. But I use Visual Composer plugin, could that maybe the problem? Backend editor in classic mode (not visual composer) looks like this http://i.imgur.com/lBryzKM.jpg

    Thanks for your support

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Focus keyword missing’ is closed to new replies.